Bug 1260362 - [abrt] tracer: processes.py:32:all:AttributeError: 'module' object has no attribute 'get_pid_list'
[abrt] tracer: processes.py:32:all:AttributeError: 'module' object has no att...
Status: CLOSED DUPLICATE of bug 1260302
Product: Fedora
Classification: Fedora
Component: tracer (Show other bugs)
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jakub Kadlčík
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2015-09-06 05:08 EDT by Heiko Adams
Modified: 2015-09-08 06:12 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2015-09-08 06:12:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
File: backtrace (1.11 KB, text/plain)
2015-09-06 05:08 EDT, Heiko Adams
no flags Details
File: environ (2.00 KB, text/plain)
2015-09-06 05:08 EDT, Heiko Adams
no flags Details

  None (edit)
Description Heiko Adams 2015-09-06 05:08:23 EDT
Description of problem:
Looked for new updates with dnf

Version-Release number of selected component:

Additional info:
reporter:       libreport-2.6.2
cmdline:        /usr/bin/python /bin/tracer -n thunderbird
executable:     /bin/tracer
kernel:         4.2.0-1.fc23.x86_64
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
processes.py:32:all:AttributeError: 'module' object has no attribute 'get_pid_list'

Traceback (most recent call last):
  File "/bin/tracer", line 34, in <module>
  File "/usr/lib/python2.7/site-packages/tracer/main.py", line 42, in run
    return router.dispatch()
  File "/usr/lib/python2.7/site-packages/tracer/resources/router.py", line 55, in dispatch
    controller = DefaultController(self.args, self.packages)
  File "/usr/lib/python2.7/site-packages/tracer/controllers/default.py", line 46, in __init__
    self.applications = self.tracer.trace_affected(self._user(args.user))
  File "/usr/lib/python2.7/site-packages/tracer/resources/tracer.py", line 80, in trace_affected
    memory = self._memory(user)
  File "/usr/lib/python2.7/site-packages/tracer/resources/memory.py", line 36, in dump_memory
    for process in Processes.all().owned_by(user).unique():
  File "/usr/lib/python2.7/site-packages/tracer/resources/processes.py", line 32, in all
    for pid in psutil.get_pid_list():
AttributeError: 'module' object has no attribute 'get_pid_list'

Local variables in innermost frame:
processes: []
Comment 1 Heiko Adams 2015-09-06 05:08:26 EDT
Created attachment 1070665 [details]
File: backtrace
Comment 2 Heiko Adams 2015-09-06 05:08:27 EDT
Created attachment 1070666 [details]
File: environ
Comment 3 Jakub Kadlčík 2015-09-08 06:12:56 EDT
Hello Heiko,
thank you for the feedback.

This issue is duplicate of 1260302 so please see the progress there.

*** This bug has been marked as a duplicate of bug 1260302 ***

Note You need to log in before you can comment on or make changes to this bug.