Bug 1260394 - plasma-desktop and plasma-workspace packages break KDE session loading
plasma-desktop and plasma-workspace packages break KDE session loading
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: plasma-desktop (Show other bugs)
22
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: KDE SIG
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On: 1261034 1262545
Blocks: F23BetaBlocker Beta0Day/F23Beta0Day
  Show dependency treegraph
 
Reported: 2015-09-06 07:30 EDT by carasin
Modified: 2015-11-18 18:36 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-18 18:36:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description carasin 2015-09-06 07:30:20 EDT
Description of problem:
I've updated my F22 KDE installation to updates-testing. Result: <plasma-desktop-5.4.0-2> and <plasma-workspace-5.4.0-6> packages together break KDE session loading: SDDM shows the white screen without any widgets / controls.

Version-Release number of selected component (if applicable):
plasma-desktop-5.4.0-2
plasma-workspace-5.4.0-6

How reproducible:
always

Steps to Reproduce:
1. # dnf --enablerepo=updates-testing update plasma-desktop plasma-workspace
or
# dnf --enablerepo=updates-testing update
2. Reboot / relogin

Actual results:
SDDM shows the white screen without any widgets / controls, it isn't able to load KDE session

Expected results:
SDDM looks themed, it loads KDE session

Additional info:
Comment 1 Rex Dieter 2015-09-07 17:06:29 EDT
Does

dnf install sddm-breeze

fix things?
Comment 2 Rex Dieter 2015-09-07 17:07:46 EDT
If so, it's either selective upgrades to blame, or 'dnf update' not processing Obsoletes tags properly.
Comment 3 Rex Dieter 2015-09-07 17:18:20 EDT
In particular, plasma-workspace.spec includes:

Summary:        SDDM breeze theme
# upgrade path, when sddm-breeze was split out
Obsoletes: plasma-workspace < 5.3.2-8
Requires:       kf5-plasma
# QML imports:
# org.kde.plasma.workspace.components
# org.kde.plasma.workspace.keyboardlayout
Requires:       %{name} = %{version}-%{release}

...

so upgrades from prior to plasma-workspace-5.3.2-8 (where sddm-breeze subpkg was introduced), should pull in sddm-breeze subpkg
Comment 4 carasin 2015-09-08 00:12:56 EDT
(In reply to Rex Dieter from comment #1)
> Does
> 
> dnf install sddm-breeze
> 
> fix things?

Yes! It fixed the issue. Thanks!

So the problem is that plasma-5.4 update does not install sddm-breeze subpkg automatically.
Comment 5 Rex Dieter 2015-09-08 09:05:41 EDT
Filed bug #1261034 to track the bad dnf behavior causing this upgrade snafu.  Will see if we can come up with some workaround(s) in the meantime.
Comment 6 Adam Williamson 2015-09-10 15:30:45 EDT
Discussed at 2015-09-10 blocker review meeting: https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2015-09-10/f23-blocker-review.2015-09-10-16.00.log.txt . #1261034 was proposed as a blocker, but we decided in discussion to take *this* bug as the blocker rather than the parent.

This bug was proposed and accepted as a 23 Beta blocker under the criterion "For each one of the release-blocking package sets, it must be possible to successfully complete an upgrade from a fully updated installation of the previous stable Fedora release with that package set installed. ...  The upgraded system must meet all release criteria." - clearly if you upgrade from 22 KDE to 23 KDE and can't log in, that's not 'meeting all release criteria'.
Comment 7 Markus S. 2015-09-12 08:54:12 EDT
Why don't you just add "Requires: sddm-breeze" to the spec file until the dnf issue is resolved?
Comment 8 Rex Dieter 2015-09-12 09:29:48 EDT
I'm seriously considering that... but the dnf bug will affect many other users and packages than just this one.
Comment 9 Rex Dieter 2015-09-12 09:37:02 EDT
Ah, now I remember the "why", because of bug #1250204 , enterprises requested we ship a userlist-less sddm theme, and the way they could achieve that was to remove sddm-breeze pkg.  If we have a hard dependency, that's no longer possible
Comment 10 Rex Dieter 2015-09-12 10:25:34 EDT
I just verified
* yum-deprecated works, respects the Obsoletes and upgrade path as expected
* PackageKit does not (like dnf), I'll file a separate bug shortly :(
Comment 11 Kevin Kofler 2015-09-12 18:27:58 EDT
> Ah, now I remember the "why", because of bug #1250204 , enterprises requested
> we ship a userlist-less sddm theme, and the way they could achieve that was
> to remove sddm-breeze pkg.  If we have a hard dependency, that's no longer
> possible

Huh? They don't have to remove sddm-breeze for that, just to install the other (Fedora) theme and set it in sddm.conf.
Comment 12 Markus S. 2015-09-12 21:13:34 EDT
(In reply to Rex Dieter from comment #9)
> Ah, now I remember the "why", because of bug #1250204 , enterprises
> requested we ship a userlist-less sddm theme, and the way they could achieve
> that was to remove sddm-breeze pkg.  If we have a hard dependency, that's no
> longer possible

So, Plasma 5.4 with many user-facing improvements is currently blocked for everybody because some enterprises can't deploy a sddm.conf to /etc with a different theme defined? Seriously?
Comment 13 Kevin Kofler 2015-09-13 06:27:59 EDT
No, it is blocked because our broken update policies allow untrusted users to DoS-sabotage any update for any (or even no) reason whatsoever.
Comment 14 Fedora Update System 2015-09-15 14:14:32 EDT
bluedevil-5.4.1-1.fc23 kde-cli-tools-5.4.1-1.fc23 kde-gtk-config-5.4.1-1.fc23 kdecoration-5.4.1-1.fc23 kdeplasma-addons-5.4.1-1.fc23 kf5-kwayland-5.4.1-1.fc23 khelpcenter-5.4.1-1.fc23 khotkeys-5.4.1-1.fc23 kinfocenter-5.4.1-1.fc23 kio-extras-15.08.1-1.fc23 kmenuedit-5.4.1-1.fc23 kscreen-5.4.1-1.fc23 ksshaskpass-5.4.1-1.fc23 ksysguard-5.4.1-1.fc23 kwayland-integration-5.4.1-1.fc23 kwin-5.4.1-1.fc23 kwrited-5.4.1-1.fc23 libkscreen-qt5-5.4.1-1.fc23 libksysguard-5.4.1-1.fc23 muon-5.4.1-1.fc23 oxygen-fonts-5.4.1-1.fc23 plasma-breeze-5.4.1-1.fc23 plasma-desktop-5.4.1-2.fc23 plasma-milou-5.4.1-1.fc23 plasma-nm-5.4.1-1.fc23 plasma-oxygen-5.4.1-1.fc23 plasma-pa-5.4.1-1.fc23 plasma-sdk-5.4.1-1.fc23 plasma-systemsettings-5.4.1-1.fc23 plasma-workspace-5.4.1-4.fc23 plasma-workspace-wallpapers-5.4.1-1.fc23 polkit-kde-5.4.1-1.fc23 powerdevil-5.4.1-1.fc23 sddm-kcm-5.4.1-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-15684
Comment 15 Fedora Update System 2015-09-15 14:14:32 EDT
bluedevil-5.4.1-1.fc23 kde-cli-tools-5.4.1-1.fc23 kde-gtk-config-5.4.1-1.fc23 kdecoration-5.4.1-1.fc23 kdeplasma-addons-5.4.1-1.fc23 kf5-kwayland-5.4.1-1.fc23 khelpcenter-5.4.1-1.fc23 khotkeys-5.4.1-1.fc23 kinfocenter-5.4.1-1.fc23 kio-extras-15.08.1-1.fc23 kmenuedit-5.4.1-1.fc23 kscreen-5.4.1-1.fc23 ksshaskpass-5.4.1-1.fc23 ksysguard-5.4.1-1.fc23 kwayland-integration-5.4.1-1.fc23 kwin-5.4.1-1.fc23 kwrited-5.4.1-1.fc23 libkscreen-qt5-5.4.1-1.fc23 libksysguard-5.4.1-1.fc23 muon-5.4.1-1.fc23 oxygen-fonts-5.4.1-1.fc23 plasma-breeze-5.4.1-1.fc23 plasma-desktop-5.4.1-2.fc23 plasma-milou-5.4.1-1.fc23 plasma-nm-5.4.1-1.fc23 plasma-oxygen-5.4.1-1.fc23 plasma-pa-5.4.1-1.fc23 plasma-sdk-5.4.1-1.fc23 plasma-systemsettings-5.4.1-1.fc23 plasma-workspace-5.4.1-4.fc23 plasma-workspace-wallpapers-5.4.1-1.fc23 polkit-kde-5.4.1-1.fc23 powerdevil-5.4.1-1.fc23 sddm-kcm-5.4.1-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-15684
Comment 16 Adam Williamson 2015-09-15 19:02:16 EDT
go home, Bugzilla. You're drunk.
Comment 17 Fedora Update System 2015-09-16 00:53:00 EDT
bluedevil-5.4.1-1.fc23, kde-cli-tools-5.4.1-1.fc23, kde-gtk-config-5.4.1-1.fc23, kdecoration-5.4.1-1.fc23, kdeplasma-addons-5.4.1-1.fc23, kf5-kwayland-5.4.1-1.fc23, khelpcenter-5.4.1-1.fc23, khotkeys-5.4.1-1.fc23, kinfocenter-5.4.1-1.fc23, kio-extras-15.08.1-1.fc23, kmenuedit-5.4.1-1.fc23, kscreen-5.4.1-1.fc23, ksshaskpass-5.4.1-1.fc23, ksysguard-5.4.1-1.fc23, kwayland-integration-5.4.1-1.fc23, kwin-5.4.1-1.fc23, kwrited-5.4.1-1.fc23, libkscreen-qt5-5.4.1-1.fc23, libksysguard-5.4.1-1.fc23, muon-5.4.1-1.fc23, oxygen-fonts-5.4.1-1.fc23, plasma-breeze-5.4.1-1.fc23, plasma-desktop-5.4.1-2.fc23, plasma-milou-5.4.1-1.fc23, plasma-nm-5.4.1-1.fc23, plasma-oxygen-5.4.1-1.fc23, plasma-pa-5.4.1-1.fc23, plasma-sdk-5.4.1-1.fc23, plasma-systemsettings-5.4.1-1.fc23, plasma-workspace-5.4.1-4.fc23, plasma-workspace-wallpapers-5.4.1-1.fc23, polkit-kde-5.4.1-1.fc23, powerdevil-5.4.1-1.fc23, sddm-kcm-5.4.1-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update kwrited kio-extras plasma-pa plasma-workspace kf5-kwayland sddm-kcm plasma-sdk plasma-workspace-wallpapers kscreen kdeplasma-addons plasma-systemsettings kdecoration oxygen-fonts libksysguard kwayland-integration kmenuedit plasma-breeze kwin ksysguard bluedevil plasma-desktop ksshaskpass kde-cli-tools kinfocenter plasma-milou powerdevil muon khotkeys plasma-nm khelpcenter libkscreen-qt5 kde-gtk-config plasma-oxygen polkit-kde'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-15684
Comment 18 Adam Williamson 2015-09-17 12:33:46 EDT
For the record, this is being treated as a 'special blocker', which in context means we're requiring the update be in the 0-day stable push for Beta. I'm putting it on my todo list to come up with a better process for 'special blockers' (bugs that are sort of release blockers but don't require the packages to go into the frozen repos / media).
Comment 19 Fedora Update System 2015-09-19 14:54:33 EDT
bluedevil-5.4.1-1.fc23, kde-cli-tools-5.4.1-1.fc23, kde-gtk-config-5.4.1-1.fc23, kdecoration-5.4.1-1.fc23, kdeplasma-addons-5.4.1-1.fc23, kf5-kwayland-5.4.1-1.fc23, khelpcenter-5.4.1-1.fc23, khotkeys-5.4.1-1.fc23, kinfocenter-5.4.1-1.fc23, kio-extras-15.08.1-1.fc23, kmenuedit-5.4.1-1.fc23, kscreen-5.4.1-1.fc23, ksshaskpass-5.4.1-1.fc23, ksysguard-5.4.1-1.fc23, kwayland-integration-5.4.1-1.fc23, kwin-5.4.1-1.fc23, kwrited-5.4.1-1.fc23, libkscreen-qt5-5.4.1-1.fc23, libksysguard-5.4.1-1.fc23, muon-5.4.1-1.fc23, oxygen-fonts-5.4.1-1.fc23, plasma-breeze-5.4.1-1.fc23, plasma-desktop-5.4.1-2.fc23, plasma-milou-5.4.1-1.fc23, plasma-nm-5.4.1-1.fc23, plasma-oxygen-5.4.1-1.fc23, plasma-pa-5.4.1-1.fc23, plasma-sdk-5.4.1-1.fc23, plasma-systemsettings-5.4.1-1.fc23, plasma-workspace-5.4.1-4.fc23, plasma-workspace-wallpapers-5.4.1-1.fc23, polkit-kde-5.4.1-1.fc23, powerdevil-5.4.1-1.fc23, sddm-kcm-5.4.1-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 20 Adam Williamson 2015-11-18 18:36:09 EST
Update was pushed stable long ago, closing.

Note You need to log in before you can comment on or make changes to this bug.