Bug 1260416 - [IMAPx] Move to real Trash keeps original message with UID COPY
[IMAPx] Move to real Trash keeps original message with UID COPY
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
23
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Milan Crha
Fedora Extras Quality Assurance
:
: 1261865 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-06 11:32 EDT by Heiko Adams
Modified: 2015-09-10 08:02 EDT (History)
5 users (show)

See Also:
Fixed In Version: evolution-data-server-3.17.92
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-07 12:40:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Logfile (10.12 KB, text/plain)
2015-09-07 08:31 EDT, Heiko Adams
no flags Details

  None (edit)
Description Heiko Adams 2015-09-06 11:32:09 EDT
Description of problem:
After updating evolution to 3.17.91 I noticed that evolution fails to delete mails from imap-accounts.

Version-Release number of selected component (if applicable):
$ rpm -qa evolution\*
evolution-3.17.91-1.fc23.x86_64
evolution-data-server-3.17.91-1.fc23.x86_64
evolution-help-3.17.91-1.fc23.noarch

How reproducible:
allways

Steps to Reproduce:
1. Delete a mail from an imap-account
2. Switch to anouther folder
3. switch back to the folder you deleted the mail from

Actual results:
The mail that should be deleted is still present

Expected results:
The mail should be deleted and no longer present

Additional info:
Comment 1 Milan Crha 2015-09-07 06:32:20 EDT
Thanks for a bug report. There had been done related changes for evolution-data-serer 3.17.92, namely commits named:
   [IMAPx] Junk/NotJunk message flags not stored server-side
   Bug 402843 - Remove Junk/Deleted flag when moving out of real Junk/Trash folder
   [IMAPx] Local changes not always properly saved to the server

The actual behaviour also depends on the account settings, whether you use real trash folder or not. I do not use the real trash folder and when I a delete message in it and move away from the folder, then when I return back to it the message stays deleted (View->Show Deleted messages is turned off).

The 3.17.92 will be released the next week, I guess we should figure out what's broken during this week. I'll create a test package for you, thus you could give it a try before the release.
Comment 2 Milan Crha 2015-09-07 07:49:49 EDT
The test build with changes since commit 5fc753eba55b is here:
http://koji.fedoraproject.org/koji/taskinfo?taskID=10984647

Give it a try, please. As it is evolution-data-server, make sure all the evolution background processes will be restarted too, which you can also do either by reboot o re-login. Thanks in advance.
Comment 3 Heiko Adams 2015-09-07 08:02:29 EDT
The problem is still present after installing your test build and rebooting the system.
Comment 4 Milan Crha 2015-09-07 08:20:47 EDT
Thanks for a quick test. Could you run evolution from a terminal with this command:
   $ CAMEL_DEBUG=imapx:io,imapx:conman evolution
let evolution do its initial update, then, when the activity on the console will settle, mark the log place and reproduce the issue by deleting a message, move to another folder, move back, then copy the newly added output from the marked place on the console to some file and share it, please? The log may not contain any private information, but better to search it for anything obvious, like LOGIN, AUTH, pass and similar words. If you prefer, then feel free to send the log only to me, just reference this bug report in the Subject.
Comment 5 Heiko Adams 2015-09-07 08:31:48 EDT
Created attachment 1071015 [details]
Logfile

I hope I made anything correct and this helps you
Comment 6 Milan Crha 2015-09-07 10:56:18 EDT
I see in the log that you've setup a real Trash folder on the account, the Inbox/Trash. You deleted one message in the Inbox, which got saved as a message copy into the Inbox/Trash folder, then a call of Expunge in the Inbox itself. The Expunge didn't delete anything in the Inbox, because there is missing a flag change save.

I'm pretty sure I fixed this recently, I recall the issue with the real Junk/Trash folder, but your log says the opposite. I checked the log with my Dovecot server and I see the difference, my server uses "UID MOVE", while yours "UID COPY". That means that the "UID COPY" lefts the message in the source folder, while the "UID MOVE" really moves it, thus it disappears from the source folder and is in the destination only. Avoiding the "UID MOVE" helps me reproduce the issue here. Thus I'm confirming it.
Comment 7 Milan Crha 2015-09-07 12:40:39 EDT
I fixed this upstream with commit [1]. It will be included in evolution-data-server 3.17.92. I also created another test build for you at [2].

Thanks for your help with this.

[1] https://git.gnome.org/browse/evolution-data-server/commit/?id=73d0803
[2] http://koji.fedoraproject.org/koji/taskinfo?taskID=10987464
Comment 8 Milan Crha 2015-09-10 08:02:08 EDT
*** Bug 1261865 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.