Bug 1260463 - [DOCS] Document offline installation
[DOCS] Document offline installation
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation (Show other bugs)
3.0.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: brice
Ma xiaoqiang
Vikram Goyal
:
Depends On:
Blocks: 1305675
  Show dependency treegraph
 
Reported: 2015-09-06 21:37 EDT by Vikram Goyal
Modified: 2016-05-03 18:52 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-18 22:01:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 1562403 None None None 2016-02-08 17:27 EST

  None (edit)
Description Vikram Goyal 2015-09-06 21:37:13 EDT
The current docs do not provide any information about how to install OSE 3.0 in an offline mode.

This could be a scenario common for some customers.

This should go in the install guide. Also see the attached customer case for information on how to do this.
Comment 8 brice 2016-02-16 01:09:08 EST
Initial PR (which is technically a copy of Eric's PR from comment 6) here:

https://github.com/openshift/openshift-docs/pull/1595

Hou Jianwei, can I ask for a QA on this task? I wasn't able to test this out 100% myself. Please let me know if there is any issues at all with this topic and I can work to get them into the doc.

Thanks!
Comment 14 Ma xiaoqiang 2016-03-04 03:47:07 EST
It is too slow to sync repo in BJ, QE will check it when OS1 openstack is back.
Comment 15 Ma xiaoqiang 2016-03-08 03:33:51 EST
1. the following command does not work
docker tag registry.access.redhat.com/jboss-amq-6/amq-openshift $REGISTRY:5000/openshift/amq-openshift \
    docker tag registry.access.redhat.com/jboss-eap-6/eap-openshift $REGISTRY:5000/openshift/eap-openshift \
...
Should delete "\"

2. the following command does not work
docker push $REGISTRY:5000/openshift/amq-openshift \
    docker push $REGISTRY:5000/openshift/eap-openshift \
....
should delete "\"

3. Should add service with following command
firewall-cmd --permanent  --add-service=http

4. the synced language image does not contain all images used in the iamgestream. Maybe this is not a issue.

5. I am very sorry that I provide the wrong command
"gpg --import /etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-release" should be "rpm --import /etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-release " 

6. the image stream does not work, it can not get tags
# oc get is
NAME            DOCKER REPO                                 TAGS      UPDATED
ruby            172.31.88.64:5000/openshift/ruby
Comment 16 brice 2016-03-08 20:01:44 EST
(In reply to Ma xiaoqiang from comment #15)
> 1. the following command does not work
> docker tag registry.access.redhat.com/jboss-amq-6/amq-openshift
> $REGISTRY:5000/openshift/amq-openshift \
>     docker tag registry.access.redhat.com/jboss-eap-6/eap-openshift
> $REGISTRY:5000/openshift/eap-openshift \
> ...
> Should delete "\"
> 
> 2. the following command does not work
> docker push $REGISTRY:5000/openshift/amq-openshift \
>     docker push $REGISTRY:5000/openshift/eap-openshift \
> ....
> should delete "\"

These two are my fault. I provided the wrong layout of the commands. They should work now.

> 6. the image stream does not work, it can not get tags
> # oc get is
> NAME            DOCKER REPO                                 TAGS      UPDATED
> ruby            172.31.88.64:5000/openshift/ruby

This seems to be dependent on the command above. And should work now. 

The other issues have been fixed. Can I please ask for one more test? This is an important doc and I don't want it to be incorrect.

Thanks very much!
Comment 17 Ma xiaoqiang 2016-03-09 19:16:18 EST
For the sixth issue, i mean we can not get the tag after creating the  imagestream, this issue have nothing with the command. How to fix it?
Comment 18 openshift-github-bot 2016-04-15 02:02:26 EDT
Commit pushed to master at https://github.com/openshift/openshift-docs

https://github.com/openshift/openshift-docs/commit/478f33cad2ced540959ab1a430eda48f0e2ac930
Bug 1260463 Disconnected install guide

Bug 1260463 disconnected install
Comment 22 brice 2016-05-03 18:52:16 EDT
Right. The automatic Github merge comment doesn't have the finished state, I guess.

Jaspreet, if there's any additions you'd like to make please let me know. I'm talking to a consultant who is using this in the field and trying to get as many people using it as possible.

Note You need to log in before you can comment on or make changes to this bug.