Bug 1305675 - [DOCS] Requirements for Offline Deployments or Locked down Environment.
[DOCS] Requirements for Offline Deployments or Locked down Environment.
Status: CLOSED DUPLICATE of bug 1364204
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation (Show other bugs)
Unspecified Unspecified
medium Severity high
: ---
: ---
Assigned To: brice
Jianwei Hou
Vikram Goyal
Depends On: 1260463
  Show dependency treegraph
Reported: 2016-02-08 16:16 EST by Ryan Howe
Modified: 2016-08-21 20:22 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2016-08-21 20:22:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Ryan Howe 2016-02-08 16:16:03 EST
Document URL:https://docs.openshift.com/enterprise/3.1/install_config/install/prerequisites.html 

Section Number and Name: Network Access

Describe the issue: 
- Information in Prerequisites needed on what outside network access is needed.  - List of Docker Images are needed to be pulled before hand to private registry  

Suggestions for improvement: 
3.0 KCS example --> https://access.redhat.com/solutions/1562403

Additional information: 

   - For an Offline deployment the system component images need to be pull to a private registry.  

   - For strict rules on network make sure you have your firewall open to allow traffic for 
          registry.access.redhat.com TCP/443
          access.redhat.com TCP/443
          index.docker.io TCP/443 (optional)
Comment 3 brice 2016-08-11 01:26:01 EDT

Is this to do with only disconnected install? So this doc:


Does what's there answer the questions you have above? I think the network/firewall stuff might need to be included, but I wanted to confirm whether the rest is there.

Comment 4 Ryan Howe 2016-08-16 18:56:35 EDT

The above document does list all the needed images. It is only missing information regarding what tags are needed for various images.
Comment 5 brice 2016-08-16 23:50:41 EDT

That work is being completed as part of this BZ (which we are also currently working on):


Are you saying we can close this BZ in favour of 1364204?
Comment 6 Ryan Howe 2016-08-19 13:45:50 EDT
Yes I think its safe to close this in favour of 1364204
Comment 7 brice 2016-08-21 20:22:29 EDT
Great. Thanks, Ryan.

*** This bug has been marked as a duplicate of bug 1364204 ***

Note You need to log in before you can comment on or make changes to this bug.