Bug 1260471 - SELinux policy (daemons) changes required for package: libreswan
SELinux policy (daemons) changes required for package: libreswan
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: selinux-policy (Show other bugs)
6.8
All Linux
high Severity medium
: rc
: ---
Assigned To: Miroslav Grepl
Milos Malik
: ZStream
Depends On: 1267212
Blocks: 1233303 1266223 1272437 1287182
  Show dependency treegraph
 
Reported: 2015-09-06 23:08 EDT by Eng Ops Maitai User
Modified: 2016-05-10 16:01 EDT (History)
12 users (show)

See Also:
Fixed In Version: selinux-policy-3.7.19-281.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1272437 (view as bug list)
Environment:
Last Closed: 2016-05-10 16:01:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
omoris: needinfo-


Attachments (Terms of Use)
selinux policy update for libreswan in RHEL6 (3.99 KB, patch)
2015-09-11 11:18 EDT, Paul Wouters
no flags Details | Diff

  None (edit)
Comment 1 Ondrej Moriš 2015-09-09 11:37:14 EDT
So far I experienced the following policy issue with libreswan on rhel6:

_stackmanager is denied the following read access:

# ausearch -m AVC -ts recent 
----
time->Wed Sep  9 11:29:45 2015
type=SYSCALL msg=audit(1441812585.429:249): arch=c000003e syscall=2 success=no exit=-13 a0=16edf30 a1=90800 a2=7f094c959ed8 a3=7ffeb1006430 items=0 ppid=2903 pid=2924 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=pts0 ses=3 comm="_stackmanager" exe="/bin/bash" subj=unconfined_u:system_r:ipsec_mgmt_t:s0 key=(null)
type=AVC msg=audit(1441812585.429:249): avc:  denied  { read } for  pid=2924 comm="_stackmanager" name="arch" dev=vda1 ino=165911 scontext=unconfined_u:system_r:ipsec_mgmt_t:s0 tcontext=system_u:object_r:modules_object_t:s0 tclass=dir
----
time->Wed Sep  9 11:29:48 2015
type=SYSCALL msg=audit(1441812588.225:251): arch=c000003e syscall=2 success=no exit=-13 a0=cb4f30 a1=90800 a2=7f9462863ed8 a3=7fff604fa030 items=0 ppid=3402 pid=3423 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=pts0 ses=3 comm="_stackmanager" exe="/bin/bash" subj=unconfined_u:system_r:ipsec_mgmt_t:s0 key=(null)
type=AVC msg=audit(1441812588.225:251): avc:  denied  { read } for  pid=3423 comm="_stackmanager" name="arch" dev=vda1 ino=165911 scontext=unconfined_u:system_r:ipsec_mgmt_t:s0 tcontext=system_u:object_r:modules_object_t:s0 tclass=dir

# ausearch -m AVC -ts recent | audit2allow 

#============= ipsec_mgmt_t ==============
allow ipsec_mgmt_t modules_object_t:dir read;
Comment 2 Ondrej Moriš 2015-09-09 11:45:13 EDT
(In reply to Ondrej Moriš from comment #1)
> So far I experienced the following policy issue with libreswan on rhel6:

To reproduce, just start ipsec service.
Comment 3 Miroslav Grepl 2015-09-10 11:20:11 EDT
Ondrej,
thank you for testing. Could you run some tests in permissive mode and collect all AVCs?
Comment 4 Paul Wouters 2015-09-11 11:18:54 EDT
Created attachment 1072594 [details]
selinux policy update for libreswan in RHEL6

This patch contains changes required to the selinux policy for libreswan. I'm not sure if some of this has already been backported from rhel7
Comment 5 Miroslav Grepl 2015-09-14 04:49:57 EDT
(In reply to Paul Wouters from comment #4)
> Created attachment 1072594 [details]
> selinux policy update for libreswan in RHEL6
> 
> This patch contains changes required to the selinux policy for libreswan.
> I'm not sure if some of this has already been backported from rhel7

That's great. Thank you.
Comment 12 Tuomo Soini 2016-03-07 12:24:02 EST
One more change is needed for XAUTH server mode PAM authentication:

+auth_use_pam(ipsec_t)
Comment 13 Miroslav Grepl 2016-03-14 03:51:07 EDT
(In reply to Tuomo Soini from comment #12)
> One more change is needed for XAUTH server mode PAM authentication:
> 
> +auth_use_pam(ipsec_t)

Could you create a new bug with AVCs?

Thank you.
Comment 14 Tuomo Soini 2016-03-14 04:38:06 EDT
bug #1315700 has AVCs - those should be quite same for rhel6.
Comment 16 errata-xmlrpc 2016-05-10 16:01:11 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0763.html

Note You need to log in before you can comment on or make changes to this bug.