Bug 1260611 - snapshot: from nfs-ganesha mount no content seen in .snaps/<snapshot-name> directory
snapshot: from nfs-ganesha mount no content seen in .snaps/<snapshot-name> di...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: snapshot (Show other bugs)
mainline
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Jiffin
: Triaged
Depends On:
Blocks: 1260859
  Show dependency treegraph
 
Reported: 2015-09-07 07:16 EDT by Jiffin
Modified: 2016-06-16 09:35 EDT (History)
10 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1260086
: 1260859 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:35:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiffin 2015-09-07 07:16:44 EDT
+++ This bug was initially created as a clone of Bug #1260086 +++

Description of problem:
Mounted the volume using the nfs-ganesha and took snapshot. From snapshot there is not data seen in .snaps/<snapshot-name>

Version-Release number of selected component (if applicable):
glusterfs-3.7.1-14.el7rhgs.x86_64
nfs-ganesha-2.2.0-7.el7rhgs.x86_64

How reproducible:
always

Steps to Reproduce:
1. create a volume of 6x2 type

2. configure nfs-ganesha, export the volume created in step1

3. on client mount the volume over nfs with vers=3 or 4,

3a. create some data inside the mount-point

4. enable uss using command
   gluster volume set <volname> uss on

5. create a snapshot using command,
   gluster snapshot create <snapname> <volname>

6. activate snapshot created in step 4,
   gluster snapshot activate <snapname>

7. cd /mount/point/volname/.snaps/<snapshot-name>

8. ls -lR

Actual results:
step 8 fails, as there is no data inside snapshot directory. Basically the data is not fetched.

Expected results:
Step 8 should fetch data from the server, as the data is fetched from glusterfs(native mount).

Additional info:
Comment 1 Vijay Bellur 2015-09-07 07:30:17 EDT
REVIEW: http://review.gluster.org/12117 (uss : handle `buf` variable properly in svs_glfs_readdir()) posted (#1) for review on master by jiffin tony Thottan (jthottan@redhat.com)
Comment 2 Niels de Vos 2016-06-16 09:35:09 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.