This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1260859 - snapshot: from nfs-ganesha mount no content seen in .snaps/<snapshot-name> directory
snapshot: from nfs-ganesha mount no content seen in .snaps/<snapshot-name> di...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: snapshot (Show other bugs)
3.7.4
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Jiffin
: Triaged
Depends On: 1260611
Blocks: 1260086
  Show dependency treegraph
 
Reported: 2015-09-08 01:35 EDT by Jiffin
Modified: 2015-12-01 11:45 EST (History)
12 users (show)

See Also:
Fixed In Version: glusterfs-3.7.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1260611
Environment:
Last Closed: 2015-10-14 06:29:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiffin 2015-09-08 01:35:59 EDT
+++ This bug was initially created as a clone of Bug #1260611 +++

+++ This bug was initially created as a clone of Bug #1260086 +++

Description of problem:
Mounted the volume using the nfs-ganesha and took snapshot. From snapshot there is not data seen in .snaps/<snapshot-name>

Version-Release number of selected component (if applicable):
glusterfs-3.7.1-14.el7rhgs.x86_64
nfs-ganesha-2.2.0-7.el7rhgs.x86_64

How reproducible:
always

Steps to Reproduce:
1. create a volume of 6x2 type

2. configure nfs-ganesha, export the volume created in step1

3. on client mount the volume over nfs with vers=3 or 4,

3a. create some data inside the mount-point

4. enable uss using command
   gluster volume set <volname> uss on

5. create a snapshot using command,
   gluster snapshot create <snapname> <volname>

6. activate snapshot created in step 4,
   gluster snapshot activate <snapname>

7. cd /mount/point/volname/.snaps/<snapshot-name>

8. ls -lR

Actual results:
step 8 fails, as there is no data inside snapshot directory. Basically the data is not fetched.

Expected results:
Step 8 should fetch data from the server, as the data is fetched from glusterfs(native mount).

Additional info:

--- Additional comment from Vijay Bellur on 2015-09-07 07:30:17 EDT ---

REVIEW: http://review.gluster.org/12117 (uss : handle `buf` variable properly in svs_glfs_readdir()) posted (#1) for review on master by jiffin tony Thottan (jthottan@redhat.com)
Comment 1 Vijay Bellur 2015-09-08 02:33:10 EDT
REVIEW: http://review.gluster.org/12122 (uss : handle `buf` variable properly in svs_glfs_readdir()) posted (#2) for review on release-3.7 by jiffin tony Thottan (jthottan@redhat.com)
Comment 2 Vijay Bellur 2015-09-09 08:16:45 EDT
COMMIT: http://review.gluster.org/12122 committed in release-3.7 by Raghavendra Bhat (raghavendra@redhat.com) 
------
commit b41579d839a8b6a1447dbb76c85aefdd44cedafe
Author: Jiffin Tony Thottan <jthottan@redhat.com>
Date:   Mon Sep 7 16:46:48 2015 +0530

    uss : handle `buf` variable properly in svs_glfs_readdir()
    
    The svs_glfs_readdir() is a generic function which is called from
    svs_readdir() and svs_readdirp(). But in svs_readdir 'buf' variable
    is passed as NULL, then glfs_read_readdir() will fail. This patch
    will fix the same.
    
    It is backport of http://review.gluster.org/12117
    
    Upstream Reference:
    > Change-Id: Id02e4e17e30c85de117db5ddd9f97b578622dff9
    > BUG: 1260611
    > Signed-off-by: Jiffin Tony Thottan <jthottan@redhat.com>
    > cherry-picked as 7b6183c36ebfe020b724c95b018a8cd535e1ecdd
    
    Change-Id: Iee08d5c29cad0376ca9d378c8f17b0820eebc88a
    BUG: 1260859
    Signed-off-by: Jiffin Tony Thottan <jthottan@redhat.com>
    Reviewed-on: http://review.gluster.org/12122
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-by: Raghavendra Bhat <raghavendra@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
Comment 3 Pranith Kumar K 2015-10-14 06:29:23 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-glusterfs-3.7.5, please open a new bug report.

glusterfs-glusterfs-3.7.5 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/gluster-users/2015-October/023968.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user
Comment 4 Pranith Kumar K 2015-10-14 06:38:21 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.5, please open a new bug report.

glusterfs-3.7.5 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/gluster-users/2015-October/023968.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.