Bug 1260626 - Failed to configure management network on host slot-11 due to setup networks failure
Failed to configure management network on host slot-11 due to setup networks ...
Status: CLOSED WORKSFORME
Product: ovirt-engine
Classification: oVirt
Component: General (Show other bugs)
---
Unspecified Unspecified
unspecified Severity high (vote)
: ovirt-3.6.1
: ---
Assigned To: Eliraz Levi
Petr Matyáš
network
:
Depends On:
Blocks: 1236382
  Show dependency treegraph
 
Reported: 2015-09-07 07:47 EDT by Petr Matyáš
Modified: 2016-02-10 14:16 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-15 07:57:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ylavi: ovirt‑3.6.z?
ylavi: ovirt‑4.0.0?
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)
engine log (309.98 KB, text/plain)
2015-09-07 07:47 EDT, Petr Matyáš
no flags Details

  None (edit)
Description Petr Matyáš 2015-09-07 07:47:44 EDT
Created attachment 1070985 [details]
engine log

Description of problem:
After installation of host I get this error, I can't change the logical network even manually in hosts network subtab.

Version-Release number of selected component (if applicable):
ovirt-engine-3.6.0-0.0.master.20150901142040.git8df944a.el6.noarch

How reproducible:
always

Steps to Reproduce:
1. install ovirt engine 3.6
2. add clean host on rhel 7.1
3.

Actual results:
error in network setup

Expected results:
correct installation of host

Additional info:
Comment 1 Petr Matyáš 2015-09-07 08:24:58 EDT
The issue is that gateway is not passed correctly to the engine (I have static IP on host), so if you set the gateway manually, it works correctly.
Comment 2 Yaniv Lavi 2015-10-07 06:09:00 EDT
Did you config the gateway when setting up the management network on the host?
Comment 3 Petr Matyáš 2015-10-08 03:33:49 EDT
(In reply to Yaniv Dary from comment #2)
> Did you config the gateway when setting up the management network on the
> host?

I don't know how do you mean that, but I set the network (ip, gateway, netmask) and then I added the host to RHEVM, which set the management network.
Comment 4 Petr Matyáš 2015-10-08 08:32:44 EDT
Although this behaves differently on virtual host and on physical machine. Even though both machines have the same system (RHEL 7.1), virtual host can be installed correctly with static ip, physical machine can not.
Comment 5 Yaniv Lavi 2015-10-14 10:40:22 EDT
(In reply to Petr Matyáš from comment #3)
> (In reply to Yaniv Dary from comment #2)
> > Did you config the gateway when setting up the management network on the
> > host?
> 
> I don't know how do you mean that, but I set the network (ip, gateway,
> netmask) and then I added the host to RHEVM, which set the management
> network.

Did you set gateway in the nic config file on the host prior to doing setup-networks?
Comment 6 Petr Matyáš 2015-10-15 02:47:46 EDT
(In reply to Yaniv Dary from comment #5)
> (In reply to Petr Matyáš from comment #3)
> > (In reply to Yaniv Dary from comment #2)
> > > Did you config the gateway when setting up the management network on the
> > > host?
> > 
> > I don't know how do you mean that, but I set the network (ip, gateway,
> > netmask) and then I added the host to RHEVM, which set the management
> > network.
> 
> Did you set gateway in the nic config file on the host prior to doing
> setup-networks?

Yes

Also I managed to reproduce this bug a few days ago.
Comment 7 Yaniv Lavi 2015-10-15 03:12:24 EDT
Is this flow supported?
Comment 8 Dan Kenigsberg 2015-10-15 05:04:52 EDT
I did not understand the flow yet.

Can you share your ifcfg-* files on the host, and the output of
vdsClient -s 0 getVdsCaps?
Comment 9 Petr Matyáš 2015-10-15 07:57:06 EDT
This must have been fixed by something else, because I can't reproduce this bug on 3.6.0-16

The flow was:
1) install RHEL 7.2
2) set network as static (with IP, gateway and netmask) in ifcfg file
3) install as host in RHEVM 3.6

Note You need to log in before you can comment on or make changes to this bug.