Bug 1260637 - sharding - Do not expose internal sharding xattrs to the application.
sharding - Do not expose internal sharding xattrs to the application.
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: sharding (Show other bugs)
mainline
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Krutika Dhananjay
bugs@gluster.org
: Triaged
Depends On:
Blocks: 1261008
  Show dependency treegraph
 
Reported: 2015-09-07 08:07 EDT by Krutika Dhananjay
Modified: 2016-06-16 09:35 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1261008 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:35:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Krutika Dhananjay 2015-09-07 08:07:52 EDT
Description of problem:
Sharding xattrs are exposed on the mountpoint. It is also possible for the application to tamper with these values from the mountpoint. This should be disallowed.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Vijay Bellur 2015-09-08 01:36:21 EDT
REVIEW: http://review.gluster.org/12121 (features/shard: Filter internal shard xattrs in {get,remove,set}xattr) posted (#1) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 2 Vijay Bellur 2015-09-08 03:10:21 EDT
REVIEW: http://review.gluster.org/12121 (features/shard: Filter internal shard xattrs in {get,remove,set}xattr) posted (#2) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 3 Vijay Bellur 2015-09-08 06:51:07 EDT
REVIEW: http://review.gluster.org/12121 (features/shard: Filter internal shard xattrs in {get,remove,set}xattr) posted (#3) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 4 Vijay Bellur 2015-09-08 07:20:32 EDT
REVIEW: http://review.gluster.org/12121 (features/shard: Filter internal shard xattrs in {get,remove,set}xattr) posted (#4) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 5 Vijay Bellur 2015-09-08 22:14:13 EDT
COMMIT: http://review.gluster.org/12121 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit ccb52e0cba557a792b9227c86155a2dc8e29f44f
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Tue Sep 8 08:22:23 2015 +0530

    features/shard: Filter internal shard xattrs in {get,remove,set}xattr
    
    Change-Id: I40e4a5dbd13d6c3d777e7e01f93dabc83e52b137
    BUG: 1260637
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: http://review.gluster.org/12121
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
Comment 6 Vijay Bellur 2015-09-09 02:25:50 EDT
REVIEW: http://review.gluster.org/12136 (features/shard: Add appropriate NULL checks to prevent excessive logging) posted (#1) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 7 Vijay Bellur 2015-09-10 08:58:03 EDT
REVIEW: http://review.gluster.org/12136 (features/shard: Add appropriate NULL checks to prevent excessive logging) posted (#2) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 8 Vijay Bellur 2015-09-12 03:19:32 EDT
REVIEW: http://review.gluster.org/12136 (features/shard: Add appropriate NULL checks to prevent excessive logging) posted (#3) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 9 Vijay Bellur 2015-09-14 01:06:22 EDT
COMMIT: http://review.gluster.org/12136 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 605e47fe69a7e11f09f95699348dfab4bbab03ff
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Wed Sep 9 08:34:08 2015 +0530

    features/shard: Add appropriate NULL checks to prevent excessive logging
    
    Also,
    1) the getxattr() callback must check for the fop return status
       before attempting to delete the internal keys.
    2) the correct dict was not being used in shard_getxattr_cbk(). This
    patch also fixes that issue.
    
    Change-Id: I516a1d98e112b572bcec7d1f1e03e23152567be3
    BUG: 1260637
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: http://review.gluster.org/12136
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
Comment 10 Niels de Vos 2016-06-16 09:35:09 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.