Bug 1261008 - sharding - Do not expose internal sharding xattrs to the application.
sharding - Do not expose internal sharding xattrs to the application.
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: sharding (Show other bugs)
3.7.4
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Krutika Dhananjay
bugs@gluster.org
: Triaged
Depends On: 1260637
Blocks: Gluster-HC-1 glusterfs-3.7.5
  Show dependency treegraph
 
Reported: 2015-09-08 08:13 EDT by Krutika Dhananjay
Modified: 2015-12-01 11:45 EST (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.7.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1260637
Environment:
Last Closed: 2015-10-14 06:29:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Krutika Dhananjay 2015-09-08 08:13:02 EDT
+++ This bug was initially created as a clone of Bug #1260637 +++

Description of problem:
Sharding xattrs are exposed on the mountpoint. It is also possible for the application to tamper with these values from the mountpoint. This should be disallowed.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Vijay Bellur on 2015-09-08 01:36:21 EDT ---

REVIEW: http://review.gluster.org/12121 (features/shard: Filter internal shard xattrs in {get,remove,set}xattr) posted (#1) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

--- Additional comment from Vijay Bellur on 2015-09-08 03:10:21 EDT ---

REVIEW: http://review.gluster.org/12121 (features/shard: Filter internal shard xattrs in {get,remove,set}xattr) posted (#2) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

--- Additional comment from Vijay Bellur on 2015-09-08 06:51:07 EDT ---

REVIEW: http://review.gluster.org/12121 (features/shard: Filter internal shard xattrs in {get,remove,set}xattr) posted (#3) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

--- Additional comment from Vijay Bellur on 2015-09-08 07:20:32 EDT ---

REVIEW: http://review.gluster.org/12121 (features/shard: Filter internal shard xattrs in {get,remove,set}xattr) posted (#4) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 1 Vijay Bellur 2015-09-08 08:22:22 EDT
REVIEW: http://review.gluster.org/12127 (features/shard: Filter internal shard xattrs in {get,remove,set}xattr) posted (#1) for review on release-3.7 by Krutika Dhananjay (kdhananj@redhat.com)
Comment 2 Vijay Bellur 2015-09-09 02:36:28 EDT
REVIEW: http://review.gluster.org/12127 (features/shard: Filter internal shard xattrs in {get,remove,set}xattr) posted (#2) for review on release-3.7 by Krutika Dhananjay (kdhananj@redhat.com)
Comment 3 Vijay Bellur 2015-09-14 01:02:47 EDT
COMMIT: http://review.gluster.org/12127 committed in release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit e89b7dc4f88644cb4538bd1dd3cd493028808bd6
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Tue Sep 8 08:22:23 2015 +0530

    features/shard: Filter internal shard xattrs in {get,remove,set}xattr
    
            Backport of: http://review.gluster.org/#/c/12121/ and
                         http://review.gluster.org/#/c/12136/
    
    Change-Id: Ifadebe1cda80fa4a525605e10513e6e64ee72709
    BUG: 1261008
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: http://review.gluster.org/12127
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
Comment 4 Pranith Kumar K 2015-10-14 06:29:23 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-glusterfs-3.7.5, please open a new bug report.

glusterfs-glusterfs-3.7.5 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/gluster-users/2015-October/023968.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user
Comment 5 Pranith Kumar K 2015-10-14 06:38:21 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.5, please open a new bug report.

glusterfs-3.7.5 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/gluster-users/2015-October/023968.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.