Bug 126077 - Pls revert kernel-sourcecode to kernel-source RPM name
Summary: Pls revert kernel-sourcecode to kernel-source RPM name
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-06-15 20:04 UTC by Dax Kelson
Modified: 2014-01-21 22:49 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2004-06-19 12:21:02 UTC


Attachments (Terms of Use)

Description Dax Kelson 2004-06-15 20:04:01 UTC
Description of problem:

Recently the package name of kernel-source changed to
kernel-sourcecode as workaround for yum/up2date issues.

Please revert the name back to kernel-source. 

The name kernel-source has been used for so long it is ingrained in
people's conscience, scripts, behaviors, and documentation (paper and
electronic).

Changing the name violates the law of least surprise and causes real
world breakage.

I understand that changing it back is not fun in it's own right, but
it is the Right Thing (tm) to do and has precedence (see vim, php, and
others).

Comment 1 Sitsofe Wheeler 2004-06-16 11:16:08 UTC
See bug 124853 . It was changed to avoid breaking up2date and yum. I
don't know that fedora can rename it back until FC3...

Comment 2 Matthew Miller 2004-06-16 14:37:19 UTC
Argh, please don't rename it back. One change is enough. And, the new
name is actually superior: if I'm talking about the src.rpm for vim, I
might say "download the vim source rpm". But for the kernel packages,
that's always been a needless ambiguity -- "no, the i386 package
*named kernel dash source". This makes that problem somewhat better.

Comment 3 Arjan van de Ven 2004-06-19 12:21:02 UTC
Unless there is a really compelling reason to rename again I don't see
the point.

In addition we're looking into removing kernel-sourcecode entirely and
replacing it with documentation on how to use the src.rpm instead, in
the fc3 timeframe.

Comment 4 Darin May 2004-07-30 18:54:14 UTC
The problem is that on a fresh FC2 install kernel-source-* is
installed, but then yum won't update it to the latest
kernel-sourcecode-* rpm -- this is indeed broken in current environments.

Comment 5 Seth Vidal 2004-07-30 18:59:36 UTC
you can run yum upgrade and it will work.


Note You need to log in before you can comment on or make changes to this bug.