Bug 126079 - bug in pmdisk of kernel-sourcecode
Summary: bug in pmdisk of kernel-sourcecode
Keywords:
Status: CLOSED DUPLICATE of bug 125986
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 2
Hardware: noarch
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-06-15 20:33 UTC by Joe Winegarden
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 19:04:06 UTC


Attachments (Terms of Use)

Description Joe Winegarden 2004-06-15 20:33:50 UTC
Description of problem:
There is a 'typo' on line 24 of arch/i386/power/pmdisk.S in the
newly-release kernel-sourcecode-2.6.6-1.435:
movl $swsusp_pg_dir-...
$swsusp_pg_dir is an unknown object, disallowing me to compile my own
kernel with PM_DISK included.
I changed this to match the same line in kerne-source-2.6.5-1.358:
$swapper_pg_dir-...
This allows make bzImage to complete successfully with PM_DISK
included. Suspend/Resume via pmdisk seems to work correctly with this
fix once new kernel is loaded.


Version-Release number of selected component (if applicable):
kernel-sourcecode-2.6.6-1.435

How reproducible:
Always, until modified as described.

Steps to Reproduce:
1. Modify kernel config to include software suspend (PM_DISK)
2. Attempt to make bzImage
3. Compilation fails with unknown object 'swsusp_pg_dir' error
  
Actual results:


Expected results:


Additional info:

Comment 1 Joe Winegarden 2004-06-15 20:35:46 UTC

*** This bug has been marked as a duplicate of 125986 ***

Comment 2 Red Hat Bugzilla 2006-02-21 19:04:06 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.