Bug 1260848 - Disperse volume: df -h on a nfs mount throws Invalid argument error
Disperse volume: df -h on a nfs mount throws Invalid argument error
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: disperse (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ashish Pandey
: ZStream
Depends On: 1257509 1273711
Blocks: 1261732
  Show dependency treegraph
 
Reported: 2015-09-07 23:49 EDT by Ashish Pandey
Modified: 2016-06-16 09:35 EDT (History)
8 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1257509
: 1261732 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:35:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-09-10 01:06:48 EDT
REVIEW: http://review.gluster.org/12123 (features/snap : cleanup the root loc in statfs) posted (#2) for review on master by Ashish Pandey (aspandey@redhat.com)
Comment 2 Vijay Bellur 2015-10-20 04:38:03 EDT
COMMIT: http://review.gluster.org/12123 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit cddc75e242140f8485e2377ce4e6dffe23123744
Author: Ashish Pandey <aspandey@redhat.com>
Date:   Tue Sep 8 12:27:50 2015 +0530

    features/snap : cleanup the root loc in statfs
    
    Problem : In svc_statfs function, wipe_loc is getting called on loc
              passed by nfs. This loc is being used by svc_stat which
              throws erro if loc->inode is NULL.
    
    Solution : wipe_loc should be called on local root_loc.
    
    Change-Id: I9cc5ee3b1bd9f352f2362a6d997b7b09051c0f68
    BUG: 1260848
    Signed-off-by: Ashish Pandey <aspandey@redhat.com>
    Reviewed-on: http://review.gluster.org/12123
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
Comment 3 Kaleb KEITHLEY 2015-10-22 13:00:12 EDT
changing version to mainline in order to retire pre-release.

If you know the appropriate, correct version for this bug, please
set it.
Comment 4 Kaleb KEITHLEY 2015-10-22 13:06:51 EDT
changing version to mainline in order to retire pre-release.

If you know the appropriate, correct version for this bug, please
set it.
Comment 5 Kaleb KEITHLEY 2015-10-22 13:11:18 EDT
changing version to mainline in order to retire pre-release.

If you know the appropriate, correct version for this bug, please
set it.
Comment 6 Mike McCune 2016-03-28 18:16:42 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 7 Niels de Vos 2016-06-16 09:35:52 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.