Bug 1261732 - Disperse volume: df -h on a nfs mount throws Invalid argument error
Disperse volume: df -h on a nfs mount throws Invalid argument error
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: disperse (Show other bugs)
3.7.5
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ashish Pandey
: ZStream
Depends On: 1257509 1260848 1273711
Blocks: glusterfs-3.7.6
  Show dependency treegraph
 
Reported: 2015-09-10 01:16 EDT by Ashish Pandey
Modified: 2015-11-17 00:57 EST (History)
10 users (show)

See Also:
Fixed In Version: glusterfs-3.7.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1260848
Environment:
Last Closed: 2015-11-17 00:57:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-09-10 04:26:56 EDT
REVIEW: http://review.gluster.org/12147 (features/snap : cleanup the root loc in statfs) posted (#3) for review on release-3.7 by Ashish Pandey (aspandey@redhat.com)
Comment 2 Vijay Bellur 2015-10-20 04:39:42 EDT
COMMIT: http://review.gluster.org/12147 committed in release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 4d52bf330db23a6a03fc69a405c351a5e1ea7b64
Author: Ashish Pandey <aspandey@redhat.com>
Date:   Tue Sep 8 12:27:50 2015 +0530

    features/snap : cleanup the root loc in statfs
    
    Problem : In svc_statfs function, wipe_loc is getting called on loc
              passed by nfs. This loc is being used by svc_stat which
              throws erro if loc->inode is NULL.
    
    Solution : wipe_loc should be called on local root_loc.
    Back port of http://review.gluster.org/#/c/12123/
    
    Change-Id: I9cc5ee3b1bd9f352f2362a6d997b7b09051c0f68
    BUG: 1261732
    Signed-off-by: Ashish Pandey <aspandey@redhat.com>
    Reviewed-on: http://review.gluster.org/12147
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
Comment 3 Raghavendra Talur 2015-11-17 00:57:59 EST
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.6, please open a new bug report.

glusterfs-3.7.6 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/gluster-users/2015-November/024359.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.