Bug 126085 - RHEL 4.0 has no netdump function in panic
Summary: RHEL 4.0 has no netdump function in panic
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 4.0
Hardware: i686 Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
: 126087 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-06-15 21:22 UTC by smorin
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-15 21:26:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description smorin 2004-06-15 21:22:39 UTC
Please note that there is no RHEL4.0 beta to select from the form.

From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET 
CLR 1.1.4322)

Description of problem:
REL4 has no netdump_func call in panic
   (via kernel/panic.c)

   In REL3 the panic() function had the following
   code sequence:

        if (netdump_func)
                BUG();

   In REL4 this code sequence is removed.




Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Code Inspection
2.
3.
    

Actual Results:  Code Inspection shows that the code sequence has 
been removed from RHEL3.0.

Expected Results:  Are there plans to re-introduce this functionality?

Additional info:

Comment 1 Arjan van de Ven 2004-06-15 21:26:34 UTC
Alpha 3 does not yet have netdump, we hope to add this to alpha 4.

Comment 2 Arjan van de Ven 2004-06-15 21:27:23 UTC
*** Bug 126087 has been marked as a duplicate of this bug. ***

Comment 3 Tim Burke 2004-07-19 17:29:04 UTC
Netdump didn't make it into Alpha 4 (A4). However it is in Beta 1 (B1).



Note You need to log in before you can comment on or make changes to this bug.