Bug 1260969 - [PPC64LE] Add validation when create vm with memory, that no multiplier of 256
[PPC64LE] Add validation when create vm with memory, that no multiplier of 256
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: General (Show other bugs)
---
ppc64le Linux
medium Severity high (vote)
: ovirt-4.0.0-beta
: 4.0.0
Assigned To: Shmuel Melamud
sefi litmanovich
:
Depends On:
Blocks: 1277183 1277184 RHEV4.0PPC
  Show dependency treegraph
 
Reported: 2015-09-08 06:17 EDT by Artyom
Modified: 2016-08-12 10:06 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, when VM was created on PPC architecture with memory size that is not multiple of 256, error occurred when trying to run the VM. Currently the VM creation dialog prevents user from creating a VM with non-aligned memory size on PPC architecture.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-12 10:06:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ylavi: ovirt‑4.0.0?
rule-engine: planning_ack+
rule-engine: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 56987 master MERGED engine: Check memory alignment of VMs on PPC architecture 2016-05-18 08:58 EDT

  None (edit)
Description Artyom 2015-09-08 06:17:34 EDT
Description of problem:
If I run vm under PPC cluster, with memory size not multiplier of 256(1000MB) I receive qemu error under engine log "2015-09-08 13:08:06,147 ERROR [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (ForkJoinPool-1-worker-36) [] Correlation ID: null, Call Stack: null, Custom Event ID: -1, Message: VM test is down with error. Exit message: internal error: early end of file from monitor: possible problem:
2015-09-08T10:07:41.489898Z qemu-kvm: Can't support memory configuration where RAM size 0x3e800000 or maxmem size 0x3e800000 isn't aligned to 256 MB."

Version-Release number of selected component (if applicable):
rhevm-3.6.0-0.13.master.el6.noarch
vdsm-4.17.5-1.el7ev.noarch
qemu-kvm-rhev-2.3.0-22.el7.ppc64le

How reproducible:
Always

Steps to Reproduce:
1. Create vm with 1000MB on ppc hosts
2. Run vm
3.

Actual results:
Create action success, but vm failed to run

Expected results:
If it qemu limitation, I want to validate memory size on create(update) action and give to user message, that under PPC cluster he can only have vms with memory size equal to multiplier of 256

Additional info:
I do not sure what a reason why we have such limitation from qemu for ppc, maybe it worth to check it will qemu dev team
Comment 1 Red Hat Bugzilla Rules Engine 2015-11-30 14:15:18 EST
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 2 Sandro Bonazzola 2016-05-02 06:03:57 EDT
Moving from 4.0 alpha to 4.0 beta since 4.0 alpha has been already released and bug is not ON_QA.
Comment 3 sefi litmanovich 2016-08-07 08:52:54 EDT
Verified with rhevm- 4.0.2.3-0.1.el7ev with hosts:
vdsm-4.18.10-1.el7ev
kernel version: 3.10.0 - 327.30.1.el7.ppc64le
Manufacturer:
IBM
Family:
PowerNV
Product Name:
IBM Power System S824
Version:
PowerNV 8286-42A
CPU Model Name:
POWER8E (raw), altivec supported

Cluster set to IBM POWER8 cluster.

Verified that trying to create/edit vm with 10000MB failed and the proper message appear when hovering above the memory field.
When editing/creating with a value which is multiplier of 256 action succeeds.

Note You need to log in before you can comment on or make changes to this bug.