Bug 1261074 - Adjust Firefox configuration to new extension signing policy
Adjust Firefox configuration to new extension signing policy
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa (Show other bugs)
7.1
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Petr Vobornik
Namita Soman
:
Depends On:
Blocks: 1296124
  Show dependency treegraph
 
Reported: 2015-09-08 10:09 EDT by German Parente
Modified: 2016-01-06 07:03 EST (History)
6 users (show)

See Also:
Fixed In Version: ipa-4.2.0-12.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1296124 (view as bug list)
Environment:
Last Closed: 2015-11-19 07:06:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
firefox_38_browser_config (49.76 KB, image/png)
2015-09-28 04:37 EDT, Abhijeet Kasurde
no flags Details
firefox_41_browser_config (54.02 KB, image/png)
2015-09-28 04:38 EDT, Abhijeet Kasurde
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2362 normal SHIPPED_LIVE ipa bug fix and enhancement update 2015-11-19 05:40:46 EST

  None (edit)
Description German Parente 2015-09-08 10:09:59 EDT
Description of problem:

This is a clone for upstream bug:

https://fedorahosted.org/freeipa/ticket/4906

Customer is using firefox 40.0.3

Version-Release number of selected component (if applicable): 

ipa-server-4.1.0-18.el7_1.4.x86_64

How reproducible: 

I have not reproduced but seems it can be reproduced always with firefox version 40.



Steps to Reproduce:

Install extension for kerberos auth kerberosauth.xpi in firefox 40.X

Actual results:

the extension will show as corrupted.

Expected results:


Additional info:

The workaround is here:

https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/7/html/Linux_Domain_Identity_Authentication_and_Policy_Guide/using-the-ui.html#man-configure-firefox

Basically, add in about:config the property:

network.negotiate-auth.trusted-uris: .<domain name>
Comment 2 Petr Vobornik 2015-09-17 10:25:25 EDT
The intended course of action is to show manual configuration in browserconfig.html instead of configuration with the extension for versions of Firefox >= 40.

The reasoning is:
* plan for enterprise environments was not published yet which forces as to use AMO (addons.mozilla.org)
* with AMO the user experience is worse than a manual configuration 

steps for AMO: 
* go to AMO page
* installed the extension
* go back to IPA page
* probably refresh
* click configure
* confirm

manual config:
* go to about:config
* set  network.negotiate-auth.trusted-uris with *domain.name
Comment 5 Abhijeet Kasurde 2015-09-28 04:37 EDT
Created attachment 1077898 [details]
firefox_38_browser_config
Comment 6 Abhijeet Kasurde 2015-09-28 04:38 EDT
Created attachment 1077899 [details]
firefox_41_browser_config
Comment 7 Abhijeet Kasurde 2015-09-28 04:39:24 EDT
Verified.

IPA server version :: 

ipa-server-4.2.0-12.el7.x86_64

Attached images for behavior changes.
Comment 8 errata-xmlrpc 2015-11-19 07:06:27 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2362.html

Note You need to log in before you can comment on or make changes to this bug.