Bug 1261081 - [admin portal] Can't anymore open console when VM is started in paused mode
[admin portal] Can't anymore open console when VM is started in paused mode
Status: CLOSED DUPLICATE of bug 1234932
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: nobody nobody
Pavel Stehlik
virt
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-08 10:25 EDT by Jiri Belka
Modified: 2015-09-16 05:02 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-16 05:02:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine.log (303.12 KB, application/x-gzip)
2015-09-08 10:25 EDT, Jiri Belka
no flags Details

  None (edit)
Description Jiri Belka 2015-09-08 10:25:34 EDT
Created attachment 1071382 [details]
engine.log

Description of problem:

Opening console of a VM which is started in paused mode worked in the past, this is not the case in 3.6.x. Obvious regression.

2015-09-08 16:21:25,127 DEBUG [org.ovirt.engine.ui.frontend.server.gwt.GenericApiGWTServiceImpl] (ajp-/127.0.0.1:8702-3) [] Server: RunQuery invoked!
2015-09-08 16:21:25,127 DEBUG [org.ovirt.engine.ui.frontend.server.gwt.GenericApiGWTServiceImpl] (ajp-/127.0.0.1:8702-3) [] Query type 'ConfigureConsoleOptions', Parameters 'ConfigureConsoleOptionsParams:{refresh='true', filtered='false'}'
2015-09-08 16:21:25,128 DEBUG [org.ovirt.engine.ui.frontend.server.gwt.GenericApiGWTServiceImpl] (ajp-/127.0.0.1:8702-3) [] IP '10.34.131.130', Session ID 'OoPmsnK-v0Zzu9ug2aW6jANy'
2015-09-08 16:21:25,129 TRACE [org.ovirt.engine.core.bll.ConfigureConsoleOptionsQuery] (ajp-/127.0.0.1:8702-3) [] START, ConfigureConsoleOptionsQuery(ConfigureConsoleOptionsParams:{refresh='true', filtered='false'}), log id: 61b22900
2015-09-08 16:21:25,130 TRACE [org.ovirt.engine.core.bll.GetVmByVmIdQuery] (ajp-/127.0.0.1:8702-3) [] START, GetVmByVmIdQuery(IdQueryParameters:{refresh='true', filtered='false'}), log id: 2773fab4
2015-09-08 16:21:25,147 TRACE [org.ovirt.engine.core.bll.GetVmByVmIdQuery] (ajp-/127.0.0.1:8702-3) [] FINISH, GetVmByVmIdQuery, log id: 2773fab4
2015-09-08 16:21:25,147 ERROR [org.ovirt.engine.core.bll.ConfigureConsoleOptionsQuery] (ajp-/127.0.0.1:8702-3) [] Query execution failed due to invalid inputs: Vm vdcadmin is not running.

^^^ issue?

2015-09-08 16:21:25,147 TRACE [org.ovirt.engine.core.bll.ConfigureConsoleOptionsQuery] (ajp-/127.0.0.1:8702-3) [] FINISH, ConfigureConsoleOptionsQuery, log id: 61b22900
2015-09-08 16:21:25,225 DEBUG [org.ovirt.engine.core.utils.servlet.LocaleFilter] (ajp-/127.0.0.1:8702-10) [] Incoming locale 'en-US'. Filter determined locale to be 'en-US'
2015-09-08 16:21:25,226 DEBUG [org.ovirt.engine.core.utils.servlet.LocaleFilter] (ajp-/127.0.0.1:8702-10) [] Incoming locale 'en-US'. Filter determined locale to be 'en-US'
2015-09-08 16:21:25,227 DEBUG [org.ovirt.engine.core.utils.servlet.LocaleFilter] (ajp-/127.0.0.1:8702-10) [] Incoming locale 'en-US'. Filter determined locale to be 'en-US'
2015-09-08 16:21:25,688 DEBUG [org.ovirt.engine.core.bll.lock.InMemoryLockManager] (DefaultQuartzScheduler_Worker-11) [] Before acquiring lock 'EngineLock:{exclusiveLocks='[aa6ebbcc-0402-41dc-811f-cf57d8b02d56=<VDS_INIT, >]', sharedLocks='null'}'
2015-09-08 16:21:25,688 DEBUG [org.ovirt.engine.core.bll.lock.InMemoryLockManager] (DefaultQuartzScheduler_Worker-11) [] Success acquiring lock 'EngineLock:{exclusiveLocks='[aa6ebbcc-0402-41dc-811f-cf57d8b02d56=<VDS_INIT, >]', sharedLocks='null'}' succeeded
2015-09-08 16:21:25,691 DEBUG [org.ovirt.engine.core.bll.lock.InMemoryLockManager] (DefaultQuartzScheduler_Worker-11) [] Before releasing a lock 'EngineLock:{exclusiveLocks='[aa6ebbcc-0402-41dc-811f-cf57d8b02d56=<VDS_INIT, >]', sharedLocks='null'}'
2015-09-08 16:21:25,691 DEBUG [org.ovirt.engine.core.bll.lock.InMemoryLockManager] (DefaultQuartzScheduler_Worker-11) [] The exclusive lock for key 'aa6ebbcc-0402-41dc-811f-cf57d8b02d56VDS_INIT' is released and lock is removed from map
2015-09-08 16:21:27,533 TRACE [org.ovirt.engine.core.vdsbroker.vdsbroker.ListVDSCommand] (DefaultQuartzScheduler_Worker-19) [] START, ListVDSCommand(HostName = dell-r210ii-13.rhev.lab.eng.brq.redhat.com, VdsIdAndVdsVDSCommandParametersBase:{runAsync='true', hostId='aa6ebbcc-0402-41dc-811f-cf57d8b02d56', vds='Host[dell-r210ii-13.rhev.lab.eng.brq.redhat.com,aa6ebbcc-0402-41dc-811f-cf57d8b02d56]'}), log id: 4b717729
2015-09-08 16:21:27,534 DEBUG [org.ovirt.engine.core.utils.threadpool.ThreadPoolUtil] (org.ovirt.thread.pool-7-thread-2) [] About to run task 'java.util.concurrent.FutureTask' from: java.lang.Exception
        at org.ovirt.engine.core.utils.threadpool.ThreadPoolUtil$InternalThreadExecutor.beforeExecute(ThreadPoolUtil.java:53) [utils.jar:]
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1139) [rt.jar:1.8.0_51]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) [rt.jar:1.8.0_51]
        at java.lang.Thread.run(Thread.java:745) [rt.jar:1.8.0_51]


Version-Release number of selected component (if applicable):
rhevm-backend-3.6.0-0.13.master.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. start a VM in paused mode
2. open console
3.

Actual results:
nothing happens (even no popup!)

Expected results:
should work as in the past

Additional info:
Comment 1 Jiri Belka 2015-09-08 10:26:36 EDT
Same for User Portal of course.
Comment 2 Omer Frenkel 2015-09-16 05:02:15 EDT

*** This bug has been marked as a duplicate of bug 1234932 ***

Note You need to log in before you can comment on or make changes to this bug.