Bug 1261087 - Unable to deploy heat stack from bundle catalog item
Unable to deploy heat stack from bundle catalog item
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Automate (Show other bugs)
5.4.0
Unspecified Unspecified
urgent Severity urgent
: GA
: 5.4.3
Assigned To: Tina Fitzgerald
Aziza Karol
: ZStream
Depends On: 1260436
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-08 10:33 EDT by Chris Pelland
Modified: 2015-10-22 10:33 EDT (History)
18 users (show)

See Also:
Fixed In Version: 5.4.3.0
Doc Type: Bug Fix
Doc Text:
In the previous version of CloudForms Management Engine, deploying a heat stack to multiple providers as a bundle catalog item would fail with a HTTP/1.1 400 Bad Request error. This was because the CatalogBundleInitialization and CatalogItemInitialization methods used in this case were not able to handle orchestration provisioning. They were originally designed to work with VM provisioning, before orchestration provisioning was introduced to the product. This bug was fixed by updating these methods to handle orchestration provisioning correctly. Users are now able to deploy the heat stack as a catalog bundle item in the new version of CloudForms Management Engine.
Story Points: ---
Clone Of: 1260436
Environment:
Last Closed: 2015-10-22 10:33:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 CFME Bot 2015-09-29 12:21:38 EDT
New commit detected on cfme/5.4.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=cba77ec2888c0f59b594795ffc862bc3b5419f7d

commit cba77ec2888c0f59b594795ffc862bc3b5419f7d
Merge: b421bf0 8e836ec
Author:     Greg McCullough <gmccullo@redhat.com>
AuthorDate: Tue Sep 29 12:03:48 2015 -0400
Commit:     Greg McCullough <gmccullo@redhat.com>
CommitDate: Tue Sep 29 12:03:48 2015 -0400

    Merge branch 'bz_1261087' into '5.4.z'
    
    Automate | Services | Changed CatalogItemInitialization automate method for Orchestration provisioning
    
    Applied Orchestration automate fixes.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1261087
    
    Original:
    https://github.com/ManageIQ/manageiq/pull/4416
    https://bugzilla.redhat.com/show_bug.cgi?id=1260436
    
    Clean cherry-pick except for spec test. Applying spec test patch wasn't successful since test was created after vmdb was rerooted.
    
    
    See merge request !266

 .../Provision.class/catalogiteminitization.yaml    |  14 +++
 .../__methods__/catalogiteminitialization.rb       |  15 +++
 .../catalog_item_initialization_spec.rb            | 105 +++++++++++++++++++++
 vmdb/spec/support/service_template_helper.rb       |  96 +++++++++++++++++++
 4 files changed, 230 insertions(+)
Comment 3 CFME Bot 2015-09-29 12:48:36 EDT
New commit detected on cfme_productization/master:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme_productization.git;a=commit;h=cba77ec2888c0f59b594795ffc862bc3b5419f7d

commit cba77ec2888c0f59b594795ffc862bc3b5419f7d
Merge: b421bf0 8e836ec
Author:     Greg McCullough <gmccullo@redhat.com>
AuthorDate: Tue Sep 29 12:03:48 2015 -0400
Commit:     Greg McCullough <gmccullo@redhat.com>
CommitDate: Tue Sep 29 12:03:48 2015 -0400

    Merge branch 'bz_1261087' into '5.4.z'
    
    Automate | Services | Changed CatalogItemInitialization automate method for Orchestration provisioning
    
    Applied Orchestration automate fixes.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1261087
    
    Original:
    https://github.com/ManageIQ/manageiq/pull/4416
    https://bugzilla.redhat.com/show_bug.cgi?id=1260436
    
    Clean cherry-pick except for spec test. Applying spec test patch wasn't successful since test was created after vmdb was rerooted.
    
    
    See merge request !266

 .../Provision.class/catalogiteminitization.yaml    |  14 +++
 .../__methods__/catalogiteminitialization.rb       |  15 +++
 .../catalog_item_initialization_spec.rb            | 105 +++++++++++++++++++++
 vmdb/spec/support/service_template_helper.rb       |  96 +++++++++++++++++++
 4 files changed, 230 insertions(+)
Comment 6 Aziza Karol 2015-10-09 06:56:48 EDT
Verification blocked due to issue https://bugzilla.redhat.com/show_bug.cgi?id=1270233
Comment 7 Aziza Karol 2015-10-12 03:03:32 EDT
Tina,

Can you please confirm the entry points to used to be used for the verification? 
If this is the entry point "Cloud/Orchestration/Provisioning/StateMachines/Provision/CatalogItemInitialization" to be used then this is not available in Fixed version 5.4.3


~Thanks,
Aziza
Comment 8 Tina Fitzgerald 2015-10-13 09:19:50 EDT
Hi Aziza,

The entry point is as you specified. 

There was a problem with the fix and the  "Cloud/Orchestration/Provisioning/StateMachines/Provision/CatalogItemInitialization" instance is missing in that version of 5.4.3.  The instance is included in the 5.4.3 build created yesterday. 

Thanks,
Tina
Comment 10 Aziza Karol 2015-10-19 17:19:17 EDT
Able to deploy heat stack from CF as a single catalog items for entry point  Cloud/Orchestration/Provisioning/StateMachines/Provision/CatalogItemInitialization

Also able to successfully deploy heat stack from bundle catalog item for entry point /Service/Provisioning /StateMachines/Methods/CatalogBundleInitialization

Verified:
5.4.3.1.20151013111241_1c155a5
Comment 12 errata-xmlrpc 2015-10-22 10:33:35 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1916.html

Note You need to log in before you can comment on or make changes to this bug.