Bug 1261120 - [RFE] Configurable SSH Key File For ABRT's reportuploader
Summary: [RFE] Configurable SSH Key File For ABRT's reportuploader
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libreport
Version: 6.7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Matej Habrnal
QA Contact: Martin Kyral
Petr Bokoc
URL:
Whiteboard:
Depends On: 1260742
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-09-08 15:53 UTC by Bernie Hoefer
Modified: 2019-10-10 10:10 UTC (History)
7 users (show)

Fixed In Version: libreport-2.0.9-28.el6
Doc Type: Enhancement
Doc Text:
*reporter-upload* now allows configuring optional SSH keys The *reporter-upload* tool, which is used by *abrt* to submit collected problem data, now allows you to use optional SSH key files. You can specify a key file using one of the following ways: * The `SSHPublicKey` and `SSHPrivateKey` options in the `/etc/libreport/plugins/upload.conf` configuration file. * Using *-b* and *-r* command line options for the public and private key, respectively. * Setting the `Upload_SSHPublicKey` and `Upload_SSHPrivateKey` environment variables, respectively. If none of these options or variables are used, *reporter-upload* will attempt to use the default SSH key from the user's `~/.ssh/` directory.
Clone Of:
: 1277845 1289513 (view as bug list)
Environment:
Last Closed: 2016-05-11 00:38:47 UTC


Attachments (Terms of Use)
add possibility to configure SSH keys (4.58 KB, patch)
2015-12-08 10:21 UTC, Matej Habrnal
no flags Details | Diff
uploader: add possibility to set SSH keyfiles (9.50 KB, patch)
2015-12-08 10:21 UTC, Matej Habrnal
no flags Details | Diff
spec: add uploader config files and related man page (1.04 KB, patch)
2015-12-08 10:22 UTC, Matej Habrnal
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0920 normal SHIPPED_LIVE abrt bug fix and enhancement update 2016-05-10 22:53:00 UTC

Description Bernie Hoefer 2015-09-08 15:53:07 UTC
Description of problem:
Right now, when using libreport-plugin-reportuploader with password-less scp uploads, it takes the private SSH key from /root/.ssh/id_rsa.  We would like to see this option/location configurable.


Version-Release number of selected component (if applicable):
libreport-2.0.9-24.el6.x86_64


How reproducible:
N/A


Steps to Reproduce:
N/A


Actual results:
N/A


Expected results:
N/A

Additional info:
N/A

Comment 2 Jakub Filak 2015-10-22 08:48:50 UTC
I think we need something like this:

  curl_easy_setopt(curlUp, CURLOPT_SSH_PUBLIC_KEYFILE, getenv($pub_key));
  curl_easy_setopt(curlUp, CURLOPT_SSH_PRIVATE_KEYFILE, getenv($priv_key));

Comment 4 Matej Habrnal 2015-12-08 10:19:47 UTC
Patches were pushed to rhel-6.8-staging branch.

ABRT test case: https://github.com/abrt/abrt/commit/56ca324a8dabacda9a866a39121d48a662517150

Comment 5 Matej Habrnal 2015-12-08 10:21:03 UTC
Created attachment 1103502 [details]
add possibility to configure SSH keys

Comment 6 Matej Habrnal 2015-12-08 10:21:31 UTC
Created attachment 1103503 [details]
uploader: add possibility to set SSH keyfiles

Comment 7 Matej Habrnal 2015-12-08 10:22:08 UTC
Created attachment 1103504 [details]
spec: add uploader config files and related man page

Comment 12 errata-xmlrpc 2016-05-11 00:38:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0920.html


Note You need to log in before you can comment on or make changes to this bug.