Bug 1261601 - SELinux is preventing dbus-daemon from 'execute' accesses on the file mission-control-5.
SELinux is preventing dbus-daemon from 'execute' accesses on the file mission...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
x86_64 Unspecified
medium Severity medium
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:1c51f40067b5392f6cec7d4eba7...
:
: 1261636 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-09 14:35 EDT by Ömer Fadıl Usta
Modified: 2015-09-22 05:29 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-22 05:29:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
New error log (1.99 KB, text/plain)
2015-09-11 09:36 EDT, Ömer Fadıl Usta
no flags Details

  None (edit)
Description Ömer Fadıl Usta 2015-09-09 14:35:00 EDT
Description of problem:
after a system update i have started to see this bug
SELinux is preventing dbus-daemon from 'execute' accesses on the file mission-control-5.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that dbus-daemon should be allowed execute access on the mission-control-5 file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep dbus-daemon /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:system_dbusd_t:s0-s0:c0.c1023
Target Context                system_u:object_r:telepathy_mission_control_exec_t
                              :s0
Target Objects                mission-control-5 [ file ]
Source                        dbus-daemon
Source Path                   dbus-daemon
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-146.fc24.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.3.0-0.rc0.git9.1.fc24.x86_64 #1
                              SMP Tue Sep 8 17:57:29 UTC 2015 x86_64 x86_64
Alert Count                   3
First Seen                    2015-09-09 21:27:59 EEST
Last Seen                     2015-09-09 21:30:21 EEST
Local ID                      6333d83f-28bd-4592-a926-98f55fb43b82

Raw Audit Messages
type=AVC msg=audit(1441823421.185:553): avc:  denied  { execute } for  pid=2192 comm="dbus-daemon" name="mission-control-5" dev="sda5" ino=34585 scontext=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:telepathy_mission_control_exec_t:s0 tclass=file permissive=0


Hash: dbus-daemon,system_dbusd_t,telepathy_mission_control_exec_t,file,execute

Version-Release number of selected component:
selinux-policy-3.13.1-146.fc24.noarch

Additional info:
reporter:       libreport-2.6.2
hashmarkername: setroubleshoot
kernel:         4.3.0-0.rc0.git9.1.fc24.x86_64
type:           libreport

Potential duplicate: bug 1044190
Comment 1 Miroslav Grepl 2015-09-11 09:18:24 EDT
Any chance to reproduce it after log out/in?
Comment 2 Ömer Fadıl Usta 2015-09-11 09:36:45 EDT
Created attachment 1072564 [details]
New error log

Yes , I even deleted user's whole directory including all gnome/system configs in users directory. And errors are almost same about this. Whenever i try to open "Empathy" with a dialog :
There was an error while trying to connect to the Telepathy Account Manager. The error was:

Failed to execute program org.freedesktop.Telepathy.AccountManager: Permission denied

and also the error which i have attached with this comment fron SELinux troubleshoot
Comment 3 Ömer Fadıl Usta 2015-09-11 09:38:05 EDT
I'm not sure but i need to mention that my user's shell is defined as zsh instead of bash. (I'm not sure if it is related to it or not )
Comment 4 Vít Ondruch 2015-09-11 10:37:13 EDT
(In reply to Ömer Fadıl Usta from comment #3)
> I'm not sure but i need to mention that my user's shell is defined as zsh
> instead of bash. (I'm not sure if it is related to it or not )

It is not, since I am using BASH and observe the same issues :)
Comment 5 Vít Ondruch 2015-09-12 07:05:10 EDT
Since it complains about mission control, I tried to execute it by hand and this is the result, if that makes any difference:

$ /usr/libexec/mission-control-5 

(process:24584): libnm-util-CRITICAL **: nm_ip6_route_set_prefix: assertion 'prefix <= 128' failed

(process:24584): mcd-WARNING **: request_connection_cb: RequestConnection failed: Failed to execute program org.freedesktop.Telepathy.ConnectionManager.gabble: Permission denied
Comment 6 Vít Ondruch 2015-09-19 17:57:03 EDT
Description of problem:
Interesting. This time is opened gnome-weather to get this error.

Version-Release number of selected component:
selinux-policy-3.13.1-147.fc24.noarch

Additional info:
reporter:       libreport-2.6.2
hashmarkername: setroubleshoot
kernel:         4.2.0-1.fc24.x86_64
type:           libreport
Comment 7 Ömer Fadıl Usta 2015-09-19 18:35:13 EDT
I couldn't reproduce this bug with gnome-weather also it looks like it is fixed with "Empathy" which i always hit this bug . ( Fixed after latest updates on rawhide )
Comment 8 Miroslav Grepl 2015-09-21 03:44:41 EDT
(In reply to Vít Ondruch from comment #6)
> Description of problem:
> Interesting. This time is opened gnome-weather to get this error.
> 
> Version-Release number of selected component:
> selinux-policy-3.13.1-147.fc24.noarch
> 
> Additional info:
> reporter:       libreport-2.6.2
> hashmarkername: setroubleshoot
> kernel:         4.2.0-1.fc24.x86_64
> type:           libreport

Are you still getting it with the latest rawhide?
Comment 9 Miroslav Grepl 2015-09-21 03:45:51 EDT
*** Bug 1261636 has been marked as a duplicate of this bug. ***
Comment 10 Vít Ondruch 2015-09-21 17:57:11 EDT
(In reply to Miroslav Grepl from comment #8)
I had the latest selinux-policy already installed, but todays update resolved the issue. Some notable packages from the update are:

    Upgraded gnome-session-3.16.0-3.fc24.x86_64                        rawhide/23
    Upgrade                3.17.92-1.fc24.x86_64                       @rawhide

    Upgraded gnome-weather-3.17.92-1.fc24.noarch                       @rawhide
    Upgrade                3.18.0-1.fc24.noarch                        @rawhide

    Upgraded libgweather-3.17.92-1.fc24.x86_64                         @rawhide
    Upgrade              3.18.0-1.fc24.x86_64                          @rawhide

Not sure what else could be the difference.

Please note that I also relabeled the system just to be sure.
Comment 11 Miroslav Grepl 2015-09-22 05:29:49 EDT
I would think about a combination of fixes.

Note You need to log in before you can comment on or make changes to this bug.