Bug 1261633 - RFE: enable users to change hostnames for overcloud deployments
RFE: enable users to change hostnames for overcloud deployments
Status: CLOSED DUPLICATE of bug 1278854
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-rdomanager-oscplugin (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity high
: ---
: 10.0 (Newton)
Assigned To: RHOS Maint
: FutureFeature
Depends On:
  Show dependency treegraph
Reported: 2015-09-09 15:33 EDT by Jon Thomas
Modified: 2016-04-18 03:11 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2016-04-11 07:36:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jon Thomas 2015-09-09 15:33:00 EDT
Need to be able to set the overcloud name either via template or command line in order to customize hostnames. Currently it is hardcoded to be "overcloud".

This looks like a cross component rfe. It looks like at least these locations are hardcoded for overcloud. 

/usr/lib/python2.7/site-packages/rdomanager_oscplugin/v1/overcloud_deploy.py:409:        stack_name = "overcloud"
/usr/lib/python2.7/site-packages/rdomanager_oscplugin/v1/overcloud_deploy.py:438:            orchestration_client, "overcloud")
/usr/lib/python2.7/site-packages/rdomanager_oscplugin/v1/overcloud_deploy.py:587:            'OS_CLOUDNAME': 'overcloud',

Changing these and it appears the install succeeds up until cloud init finishes and puppet starts. So likely there is something in puppet templates that needs to be changed.
Comment 3 Jon Thomas 2015-09-09 15:37:21 EDT
related https://bugzilla.redhat.com/show_bug.cgi?id=1259003
Comment 9 Mike Burns 2016-04-07 16:50:54 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 11 Mike Burns 2016-04-11 07:36:21 EDT

*** This bug has been marked as a duplicate of bug 1278854 ***

Note You need to log in before you can comment on or make changes to this bug.