Bug 1261638 - RFE: Static IP address assignment with network isolation and DHCP
RFE: Static IP address assignment with network isolation and DHCP
Status: CLOSED DUPLICATE of bug 1344174
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
urgent Severity high
: ---
: ---
Assigned To: Jiri Stransky
Arik Chernetsky
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-09 16:00 EDT by Keith Basil
Modified: 2017-01-09 10:13 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-01-09 10:13:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Keith Basil 2015-09-09 16:00:11 EDT
Description of problem:

When deploying RHEL OSP, some customers would like to have the ability to statically assign IP address to the undercloud nodes.

We should have coverage for the following networks:
- Provisioning VLAN, usually the native VLAN on a dedicated interface
- Internal API
- Storage
- Storage Management
- External (Public API and floating IPs, unless floating IPs on dedicated VLAN)
- Tenant (a single VLAN for GRE/VXLAN tunneling, a range for VLAN mode)


Additional info:

Example network isolation heat templates:
http://git.openstack.org/cgit/openstack/tripleo-heat-templates/tree/network/config/
Comment 5 Mike Burns 2016-04-07 16:50:54 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 7 Christopher Brown 2016-04-22 10:04:27 EDT
As of RHEL OSP 8.0 you can assign predictable hostnames to IP addresses which is maybe of some use to you.

https://bugzilla.redhat.com/show_bug.cgi?id=1278854
Comment 9 Dmitry Tantsur 2017-01-09 10:09:06 EST
It seems like only provisioning IP is not covered so far, right?
Comment 10 Dmitry Tantsur 2017-01-09 10:13:08 EST
We have a more detailed request for this.

*** This bug has been marked as a duplicate of bug 1344174 ***

Note You need to log in before you can comment on or make changes to this bug.