Bug 1344174 - Need to have predictable provisioning IPs as we can do for other networks.
Summary: Need to have predictable provisioning IPs as we can do for other networks.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 8.0 (Liberty)
Hardware: All
OS: Linux
medium
medium
Target Milestone: beta
: 14.0 (Rocky)
Assignee: Dan Sneddon
QA Contact: Alexander Chuzhoy
URL:
Whiteboard:
: 1261638 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-09 04:17 UTC by VIKRANT
Modified: 2019-11-14 08:20 UTC (History)
14 users (show)

Fixed In Version: openstack-tripleo-heat-templates-9.0.0-0.20180726103746.5fefd0b.el7ost
Doc Type: Enhancement
Doc Text:
OSP-Director now supports setting specific IP addresses on the Control Plane (provisioning) network, similar to the way these are set for other networks. To set the IP addresses used during provisioning, set the IPs under the "ctlplane" network, one IP address per line. These will be assigned to the nodes in order (Compute-0, Compute-1, etc.) For example:: parameter_defaults: ControllerIPs: ctlplane: - 192.168.24.251 ComputeIPs: ctlplane: - 192.168.24.252 - 192.168.24.253 See the file in /usr/share/openstack-tripleo-heat-templates/environments/ips-from-pool-ctlplane.yaml for an example of usage. Prior to this update, OSP-Director allowed the operator to choose the IP addresses used by each overcloud node on each network, but the provisioning IP addresses were random. With this update, OSP-Director supports selecting specific IP addresses for each role on every network.
Clone Of:
Environment:
Last Closed: 2019-01-11 11:47:00 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 568505 None MERGED Add ability to pre-assign IPs by role on ctlplane 2020-02-20 05:04:41 UTC
Red Hat Bugzilla 1585958 None CLOSED Backport from master tripleo-heat-templates for "Add ability to pre-assign IPs by role on ctlplane " 2019-10-28 13:46:56 UTC
Red Hat Product Errata RHEA-2019:0045 None None None 2019-01-11 11:47:58 UTC

Internal Links: 1585958

Description VIKRANT 2016-06-09 04:17:11 UTC
Description of problem:
We don't have flexibility to set the predicate IPs for the provisioning network.
Cu wants to have the control over provisioning network IPs. 

Version-Release number of selected component (if applicable):
RHEL OSP 8

How reproducible:
Everytime.

Steps to Reproduce:
- We can set the predictable IPs for all networks except provisioning network.
- We have introduced management network in RHEL OSP 8 which can also have predictable IPs. 


Actual results:
No option to have predictable IPs for provisioning network.

Expected results:
Cu wants to have predictable provisioning networks.

Additional info:

-- I suggested Cu to use management network with which they can have predictable IPs.

Cu response on suggestion : 
~~~
Having predictable IP addresses inside the provisioning network can be an alternative to the management network introduced in OSP 8.
In my specific case I already have a number of separated networks:

- nic1 : provisioning connected to an access port on the switch
- nic2: internal, storage, storage mgmt, tenant, external connected to a trunk port on the switch. This is configured in a way that the native VLAN of that port is used for floating IPs while all other VLANs are tagged.

Adding yet another network just to have access via predictable IPs wouldn't add any benefit other then having predictable IPs. On the other hand it would add unnecessary implications like:

- added administrative effort on the switches
- moving management traffic from nic1 to nic2 (yes, this could be avoided with correct templates but then again I can't just use an access port on the switch for nic1)
~~~

Comment 3 Jaromir Coufal 2016-10-18 14:37:02 UTC
Networking for Hardware Provisioning team.

Comment 4 Dmitry Tantsur 2017-01-09 15:13:08 UTC
*** Bug 1261638 has been marked as a duplicate of this bug. ***

Comment 6 Dan Sneddon 2018-07-27 19:08:30 UTC
This feature has been implemented upstream in this patch: https://review.openstack.org/#/c/568505/

It will be included in OSP 14.

Comment 13 Alexander Chuzhoy 2018-10-09 17:12:49 UTC
Verified:
Environment:
openstack-tripleo-heat-templates-9.0.0-0.20180919080941.0rc1.0rc1.el7ost.noarch

This is achievable with adding a yaml to overcloud deployment with something like:

parameter_defaults:
  <controller rolename>IPs:
    # Each controller will get an IP from the lists below, first controller, first IP
    ctlplane:
    - 10.37.168.81
    - 10.37.168.82
    - 10.37.168.83
  <compute rolename>IPs:
    # Each compute will get an IP from the lists below, first compute, first IP
    ctlplane:
    - 10.37.168.151
    - 10.37.168.152
  <CephStorage role>IPs:
    # Each ceph node will get an IP from the lists below, first node, first IP
    ctlplane:
    - 10.37.168.161
    - 10.37.168.162

Comment 15 errata-xmlrpc 2019-01-11 11:47:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:0045


Note You need to log in before you can comment on or make changes to this bug.