Bug 1261657 - RHCI Installer tab modifies the primary navigation bar behavior, and the user and RH Access dropdowns pop underneath the nav bar
RHCI Installer tab modifies the primary navigation bar behavior, and the user...
Status: CLOSED ERRATA
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: WebUI (Show other bugs)
1.0
Unspecified Unspecified
unspecified Severity unspecified
: ga
: 1.0
Assigned To: jmagen@redhat.com
Tasos Papaioannou
: Triaged
Depends On:
Blocks: rhci-sprint-16
  Show dependency treegraph
 
Reported: 2015-09-09 17:35 EDT by Matt Reid
Modified: 2016-09-13 12:21 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-13 12:21:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
User widget menu shows underneath the nav bar (8.79 KB, image/png)
2015-09-09 17:36 EDT, Matt Reid
no flags Details
Cant log out at the default resolution of the fusor-installer system from the ISO (104.05 KB, image/png)
2015-09-09 17:37 EDT, Matt Reid
no flags Details

  None (edit)
Description Matt Reid 2015-09-09 17:35:31 EDT
Description of problem:
The primary navigation bar in Satellite works the same when you're in any of the tabs, except for RHCI Installer. When you're anywhere else, hovering over the tabs reveals a dropdown with all of the subpages for that tab, and clicking on RH Access or the user widget works as expected.

When you are in RHCI Installer, on either Deployments or New Deployment, the primary nav bar no longer hovers, you have to click to see the subpages for that tab, and when you try to use RH Access or the user widget, they show underneath the nav bar (wrong z-ordering maybe?). 

Why does the behavior of the UI change so drastically when we're in one specific tab? It should function the same regardless of where you are, and act like the rest of the tabs.

Version-Release number of selected component (if applicable):
Sat 6.1.1 w/ Tech Preview RHCI Installer
Comment 1 Matt Reid 2015-09-09 17:36:36 EDT
Created attachment 1071937 [details]
User widget menu shows underneath the nav bar
Comment 2 Matt Reid 2015-09-09 17:37:34 EDT
Created attachment 1071938 [details]
Cant log out at the default resolution of the fusor-installer system from the ISO
Comment 3 jmagen@redhat.com 2015-11-15 08:37:37 EST
Matt, are you still seeing this behavior?
I don't see this behavior.
Comment 4 Matt Reid 2015-11-16 10:28:47 EST
I can see it still doing that on an install from the RHCI-6.0-RHEL-7-20151104.t.0 ISO, which is running on Sat 6.1.3.

Here are the fusor packages that are installed:
fusor-initial-setup-0.0.21-10.el7.noarch.rpm
fusor-installer-0.0.14-22.el7.noarch.rpm
fusor-selinux-1.0.0-3.el7.noarch.rpm
fusor_ovirt-0.1-9.el7.x86_64.rpm

You might be looking at a newer version than that.
Comment 7 John Matthews 2016-03-24 10:35:11 EDT
Let's investigate this for Sprint 15.
Comment 9 John Matthews 2016-04-25 16:57:16 EDT
Confirmed behavior described in original comment is seen using ISOs from TP3 RC5.
Comment 10 jmagen@redhat.com 2016-05-26 06:21:26 EDT
Two part bug

The dropdown menu showing underneath has been fixed and merged in fusor

The hover opening menu behavior was fixed in Foreman upstream, so that will not be fixed until it is included in Sat6. The bug is not major, just the user needs to click on menu item to open rather than just hovering.
Comment 11 Tasos Papaioannou 2016-06-23 09:42:14 EDT
Verified on QCI-1.2-RHEL-7-20160621.t.0 that the pop-underneath behavior has been fixed.

Do you have a link to the upstream foreman bug or corresponding Satellite BZ for the hover issue, so that we can follow it?
Comment 12 jmagen@redhat.com 2016-07-14 05:30:05 EDT
Tasos,

Here is the commit in Foreman 1.12.0-RC1 to track when it will be implemented in Sat6

https://github.com/theforeman/foreman/commit/f3bdcf6852bf1637102ea3d8328ae1d4dd0e2be3
Comment 13 John Matthews 2016-07-18 17:11:48 EDT
Joseph,

Do we have a downstream Sat6 BZ to track the foreman issue?
Comment 16 jmagen@redhat.com 2016-07-25 15:27:01 EDT
New BZ opened to track
https://bugzilla.redhat.com/show_bug.cgi?id=1359923
Comment 17 John Matthews 2016-08-02 14:45:14 EDT
QCI-1.0-RHEL-7-20160801.t.2-QCI-x86_64-dvd1.iso
Comment 18 Jesus M. Rodriguez 2016-08-02 16:21:06 EDT
This bug (1261657) fixes the hidden Admin User menu.

The broken hovering is captured by this BZ #1362676
which in turn references BZ #1360167

I recommend that we move this bug to VERIFIED.
Comment 19 Tasos Papaioannou 2016-08-04 15:08:10 EDT
Verified on QCI-1.0-RHEL-7-20160801.t.2.
Comment 21 errata-xmlrpc 2016-09-13 12:21:49 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1862

Note You need to log in before you can comment on or make changes to this bug.