Bug 1261663 - New VM host does not get network and storage from template
New VM host does not get network and storage from template
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Compute Resources (Show other bugs)
6.1.0
All Linux
unspecified Severity high (vote)
: 6.2.3
: --
Assigned To: Ohad Levy
Kedar Bidarkar
http://projects.theforeman.org/issues...
: Triaged
Depends On: 1321549
Blocks: 1287901
  Show dependency treegraph
 
Reported: 2015-09-09 18:27 EDT by Jacob Hunt
Modified: 2016-10-26 08:25 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-26 08:25:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
snap of the interfaces tab (39.31 KB, image/png)
2016-04-15 13:13 EDT, Kedar Bidarkar
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 12551 None None None 2016-04-26 13:02 EDT

  None (edit)
Description Jacob Hunt 2015-09-09 18:27:35 EDT
Description of problem:

If I create a new host and select the host group before setting deploy on -> RHEV and selecting a compute profile (bare metal is default) the template network and storage options do not get attached to the vm on the virtual machine tab. This leaves the VM with no network or storage when created in RHEV.

If I select deploy on -> RHEV and a compute profile and then change the host group the VM is deployed with the expected settings and configuration.
Comment 2 Bryan Kearney 2015-11-20 11:55:15 EST
Created redmine issue http://projects.theforeman.org/issues/12551 from this bug
Comment 5 Kedar Bidarkar 2016-04-15 13:07:24 EDT
I feel with the new Interfaces tab, this is broken for Network part, but does show up storage from the template.

Also on the Interfaces tab, it does not automatically provide
a) auto ip suggestion
b) automatically set the network info (subnet/vlan )from template


TESTED with sat62-snap8.1
Comment 6 Kedar Bidarkar 2016-04-15 13:13 EDT
Created attachment 1147740 [details]
snap of the interfaces tab

no-auto IP suggestion and no RHEV name and network inherited from profile.

Auto IP suggestion has nothing to do with the compute profile  associated but still it does now show up.
Comment 10 Marek Hulan 2016-05-12 03:33:36 EDT
During testing this I found out that we display wrong interface type for RHEV interfaces. I've sent a fix and created a BZ to track this - https://bugzilla.redhat.com/show_bug.cgi?id=1335393
Comment 13 Kedar Bidarkar 2016-10-13 13:11:18 EDT
VERIFIED With sat6.2.3-SNAP2.0

Now when we create a New VM host, we do get Network and storage info from template correctly.
Comment 15 errata-xmlrpc 2016-10-26 08:25:24 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:2108

Note You need to log in before you can comment on or make changes to this bug.