Bug 1321549 - selecting template while creating compute profile should automatically populate network and storage
Summary: selecting template while creating compute profile should automatically popula...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Compute Resources
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Ivan Necas
QA Contact: Kedar Bidarkar
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks: 1261663
TreeView+ depends on / blocked
 
Reported: 2016-03-28 10:58 UTC by Kedar Bidarkar
Modified: 2019-09-26 14:36 UTC (History)
4 users (show)

Fixed In Version: foreman-1.11.0.13-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:29:15 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 12:28:58 UTC
Foreman Issue Tracker 10978 None None None 2016-04-12 16:14:22 UTC
Foreman Issue Tracker 14041 None None None 2016-03-28 20:42:13 UTC
Foreman Issue Tracker 14572 None None None 2016-04-12 16:14:07 UTC

Description Kedar Bidarkar 2016-03-28 10:58:28 UTC
Description of problem:
selecting template while creating compute profile should automatically populate network and storage info associated to it.



Version-Release number of selected component (if applicable):
Sat62-snap5

How reproducible:


Steps to Reproduce:
1. Add RHEV compute resource
2. Update or create a compute profile, by selecting a template.
3.

Actual results:
selecting template while creating compute profile does not automatically populate network and storage info associated to it.

the UI shows up a spinner continuously. 

Expected results:
selecting template while creating compute profile should automatically populate network and storage info associated to it.

Additional info:

Comment 1 Kedar Bidarkar 2016-03-28 10:59:37 UTC
This works with Satellite6.1.8, so this is a regression with Satellite6.2

Comment 3 Kedar Bidarkar 2016-03-28 11:17:03 UTC
If "blank" Template is selected, we still cannot add "Network Interface" as it neither automatically populates nor do we have a button "Add Interface".

Also note that a image was also created and the association made, as seen from the attachment.

Comment 5 Ohad Levy 2016-03-28 14:44:15 UTC
it looks like part of this issue is already resolved at https://github.com/theforeman/foreman/commit/26eeda8011cf1c16be9446625b201c36ebe70751.

Comment 7 Kedar Bidarkar 2016-04-07 08:20:41 UTC
TESTED with sat62-snap6 

I still face the same issue.

Comment 8 Kedar Bidarkar 2016-04-07 08:21:29 UTC
small correction, TESTED With sat62-snap6.2

Comment 9 Ivan Necas 2016-04-11 10:44:31 UTC
Created redmine issue http://projects.theforeman.org/issues/14572 from this bug

Comment 10 Ivan Necas 2016-04-11 10:59:12 UTC
The original patch was not connected to the original issue, so no surprise it didn't work. I opened PRs to fix two independent issues that caused this behavior not not work:

https://github.com/theforeman/foreman/pull/3411
https://github.com/theforeman/foreman/pull/3412

Comment 11 Ivan Necas 2016-04-12 07:49:56 UTC
Both PRs merged: not for cherry-picker: we need both PRs to fix this BZ

Comment 12 Kedar Bidarkar 2016-04-15 16:45:42 UTC
VERIFIED with sat62-snap8.1

selecting template while creating compute profile now automatically populates network and storage info associated to it.

Comment 14 errata-xmlrpc 2016-07-27 09:29:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.