Bug 1261664 - Tiering status command is very cumbersome.
Tiering status command is very cumbersome.
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
3.7.5
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Lambright
bugs@gluster.org
:
Depends On: 1255693
Blocks: 1260923
  Show dependency treegraph
 
Reported: 2015-09-09 18:29 EDT by Dan Lambright
Modified: 2015-10-30 13:32 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.7.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1255693
Environment:
Last Closed: 2015-10-14 06:29:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Lambright 2015-09-09 18:29:36 EDT
+++ This bug was initially created as a clone of Bug #1255693 +++

Tiering status command is very cumbersome - needs improved syntax.

--- Additional comment from Anand Avati on 2015-08-21 06:56:14 EDT ---

REVIEW: http://review.gluster.org/11984 (cluster/tier: add gluster v tier <vol>) posted (#1) for review on master by Dan Lambright (dlambrig@redhat.com)

--- Additional comment from Anand Avati on 2015-08-21 07:05:35 EDT ---

REVIEW: http://review.gluster.org/11984 (cluster/tier: add gluster v tier <vol>) posted (#2) for review on master by Dan Lambright (dlambrig@redhat.com)

--- Additional comment from Anand Avati on 2015-08-24 00:56:51 EDT ---

REVIEW: http://review.gluster.org/11984 (cluster/tier: add gluster v tier <vol>) posted (#3) for review on master by Dan Lambright (dlambrig@redhat.com)

--- Additional comment from Anand Avati on 2015-08-25 02:40:57 EDT ---

REVIEW: http://review.gluster.org/11984 (cluster/tier: add gluster v tier <vol>) posted (#4) for review on master by Dan Lambright (dlambrig@redhat.com)

--- Additional comment from Vijay Bellur on 2015-09-02 13:33:22 EDT ---

REVIEW: http://review.gluster.org/11984 (cluster/tier: add gluster v tier <vol>) posted (#5) for review on master by Dan Lambright (dlambrig@redhat.com)

--- Additional comment from Vijay Bellur on 2015-09-04 09:50:51 EDT ---

REVIEW: http://review.gluster.org/11984 (cluster/tier: add gluster v tier <vol>) posted (#6) for review on master by Dan Lambright (dlambrig@redhat.com)

--- Additional comment from Vijay Bellur on 2015-09-06 20:49:19 EDT ---

REVIEW: http://review.gluster.org/11984 (cluster/tier: add gluster v tier <vol>) posted (#7) for review on master by Dan Lambright (dlambrig@redhat.com)

--- Additional comment from Vijay Bellur on 2015-09-08 12:24:35 EDT ---

REVIEW: http://review.gluster.org/11984 (cluster/tier: add gluster v tier <vol>) posted (#8) for review on master by Dan Lambright (dlambrig@redhat.com)

--- Additional comment from Vijay Bellur on 2015-09-09 05:49:19 EDT ---

REVIEW: http://review.gluster.org/11984 (cluster/tier: add gluster v tier <vol>) posted (#9) for review on master by Dan Lambright (dlambrig@redhat.com)

--- Additional comment from Vijay Bellur on 2015-09-09 09:26:06 EDT ---

REVIEW: http://review.gluster.org/11984 (cluster/tier: add gluster v tier <vol>) posted (#10) for review on master by Dan Lambright (dlambrig@redhat.com)
Comment 1 Vijay Bellur 2015-09-09 18:44:07 EDT
REVIEW: http://review.gluster.org/12143 (cluster/tier: add gluster v tier <vol>) posted (#1) for review on release-3.7 by Dan Lambright (dlambrig@redhat.com)
Comment 2 Vijay Bellur 2015-09-10 13:59:24 EDT
COMMIT: http://review.gluster.org/12143 committed in release-3.7 by Dan Lambright (dlambrig@redhat.com) 
------
commit 0628c77f9069e93c49993722ac577becfcf902db
Author: Dan Lambright <dlambrig@redhat.com>
Date:   Fri Aug 21 06:45:46 2015 -0400

    cluster/tier: add gluster v tier <vol>
    
    This is a backport of 11984.
    
    > Currently the tier feature piggy backs off the rebalance command
    > syntax to obtain status and this is clumsy. Introduce a new
    > tier command that can do tier specific operations, starting
    > with volume status to display counters.
    
    > Old commands:
    > gluster volume attach-tier <vol> [replica count] {bricklist..}
    > gluster volume detach-tier <vol> {start|stop|commit}
    
    > New commands:
    > gluster volume tier <vol> attach [replica count] {bricklist} |
    >                           detach {start|stop|commit} |
    >                           status
    
    > Change-Id: Ic07b3c6260588162de7d34380f8cbd3d8a7f35d3
    > BUG: 1255693
    > Signed-off-by: Dan Lambright <dlambrig@redhat.com>
    > Reviewed-on: http://review.gluster.org/11984
    > Reviewed-by: Gaurav Kumar Garg <ggarg@redhat.com>
    > Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Signed-off-by: Dan Lambright <dlambrig@redhat.com>
    
    Change-Id: Id45bd0fa6b8606dd47863de83a694908da393229
    BUG: 1261664
    Signed-off-by: Dan Lambright <dlambrig@redhat.com>
    Reviewed-on: http://review.gluster.org/12143
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Gaurav Kumar Garg <ggarg@redhat.com>
Comment 3 Pranith Kumar K 2015-10-14 06:29:23 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-glusterfs-3.7.5, please open a new bug report.

glusterfs-glusterfs-3.7.5 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/gluster-users/2015-October/023968.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user
Comment 4 Pranith Kumar K 2015-10-14 06:38:21 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.5, please open a new bug report.

glusterfs-3.7.5 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/gluster-users/2015-October/023968.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.