Bug 126181 - Nautilus will not run
Nautilus will not run
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ORBit2 (Show other bugs)
2
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
:
: 123066 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-17 03:07 EDT by Lamont Peterson
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.10.0-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-28 02:53:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace output when trying to start nautilus (595.62 KB, text/plain)
2004-07-15 22:26 EDT, Lamont Peterson
no flags Details
New SRPM with fix patch (2.10.0-3) (636.66 KB, application/x-rpm)
2004-07-24 22:48 EDT, Lamont Peterson
no flags Details
ORBit2-2.10.0-aligned-access.patch (500 bytes, patch)
2004-07-27 03:52 EDT, Mark McLoughlin
no flags Details | Diff
ORBit2-2.10.0-aligned-access.patch (983 bytes, patch)
2004-07-27 04:05 EDT, Mark McLoughlin
no flags Details | Diff

  None (edit)
Description Lamont Peterson 2004-06-17 03:07:49 EDT
Description of problem:
Nautilus crashes at login and will not run when started manually, either.

Version-Release number of selected component (if applicable):
Version shipped w/FC2 (gnome-2.6).

How reproducible:
Log in.

Steps to Reproduce:
1.  Install FC2
2.  Boot system
3.  Log-in (using Gnome for the desktop)
  
Actual results:
Nautilus crashes w/a dialog reporting so.  The choices presented are
to try to restart the app or generate a bug report for the
"developers".  However, I can only click on a "Restart Application"
button and a "Cancel" button.  There is no way provided to generate a
"bug report".

There is root window desktop, however the taskbar runs just fine.

When I try to use a nautilus window (for file system surfing), it also
fails in the same manner.

Expected results:
Nautilus in the root window.  Nautilus as a file browsing window.

Additional info:
There is nothing in the logs to be of assistance.
Comment 1 Lamont Peterson 2004-07-12 03:33:21 EDT
I was able to get nautilus to produce this syslog message:

Jul 12 01:24:40 valkyrie kernel: nautilus[2610]: segfault at
00000002fffffffe rip 0000003a82d2d22b rsp 0000007fbfffeba0 error 4

That is it.  Only the one message each time I try to run it.
Comment 2 Lamont Peterson 2004-07-15 22:26:48 EDT
Created attachment 101952 [details]
strace output when trying to start nautilus

I ran:

strace nautilus 2> nautilus-strace

from within a Gnome Xsession logged in as a standard, un-privileged user.
Comment 3 Lamont Peterson 2004-07-24 16:37:58 EDT
After further research, I found this in the upstream bugzilla for Gnome:

http://bugzilla.gnome.org/show_bug.cgi?id=109799

However, as I started to edit the spec file for ORBit-0.5.17 to add
this patch and try it, I found that it was already present.

Therefore, this patch does NOT fix this bug (bugzilla.redhat.com #126181).
Comment 4 Lamont Peterson 2004-07-24 22:48:44 EDT
Created attachment 102198 [details]
New SRPM with fix patch (2.10.0-3)

This SRPM contains a patch (plus minor spec file clean-up) that fixes this bug.
Comment 5 Mark McLoughlin 2004-07-27 03:52:22 EDT
Created attachment 102213 [details]
ORBit2-2.10.0-aligned-access.patch

Attaching actual patch here for reference
Comment 6 Mark McLoughlin 2004-07-27 04:04:09 EDT
Upstream bug report:

  http://bugzilla.gnome.org/show_bug.cgi?id=138986

Lamont, thanks for tracking the patch down and testing it out - very
helpful. I'll try and get an FC2 update out witht the fix soon.
Comment 7 Mark McLoughlin 2004-07-27 04:05:31 EDT
Created attachment 102214 [details]
ORBit2-2.10.0-aligned-access.patch

Actual patch which was committed upstream - includes a union alignment fix too
Comment 8 Mark McLoughlin 2004-07-28 02:53:46 EDT
ORBit2-2.10.0-4 has been pushed to FC2 updates with the fix. A mail
should hit fedora-announce-list soon with the details.

This update can be downloaded from:
  http://download.fedora.redhat.com/pub/fedora/linux/core/updates/2/

Oh, and 2.10.0-5 in rawhide has the fix too.

Thanks Lamont

Comment 9 Michal Jaegermann 2004-07-28 12:18:39 EDT
This seems to fix also bug #123066; at least for me.

Thanks.
Comment 10 Mark McLoughlin 2004-07-28 12:56:14 EDT
*** Bug 123066 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.