Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 123066 - With two floppies nautilus crashes on a startup
With two floppies nautilus crashes on a startup
Status: CLOSED DUPLICATE of bug 126181
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-11 18:47 EDT by Michal Jaegermann
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:03:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Resutls of starting nautilus with two floppies (6.03 KB, text/plain)
2004-05-11 18:48 EDT, Michal Jaegermann
no flags Details
This is the bug report bug buddy created including a trace. (10.53 KB, text/plain)
2004-05-28 01:45 EDT, Mark Lane
no flags Details

  None (edit)
Description Michal Jaegermann 2004-05-11 18:47:23 EDT
Description of problem:

With two floppy mechanisms attached, one "regular" and one USB,
nautilus invariably crashes on a startup.  A backtrace, without
all "no symbols", attached.  With two floppies /etc/fstab
has the following lines in it:

/dev/fd0        /mnt/floppy             auto    noauto,owner,kudzu 0 0
/dev/sda        /mnt/floppy1            auto    noauto,owner,kudzu 0 0

When USB floppy is detached then the second line is removed from
/etc/fstab and then nautilus can be started manually but not
earlier.  Reattaching USB floppy again is _not_ causing the
last line to reappear (see Bug 122837) unless updfstab is run
explicitely "by hand". Before the last action /dev/sda can be mounted
by root and after it an icon "Floppy 2", which refers to "floppy1",
does show up in "Computer" icons and clicking on it will get
media mounted (provided there is no "bad" console ownership :-).
There are no further trouble; only a startup after a login croaks.

A nautilus crash looks the same regardless if a non-root user
or root is trying to perform actions.

Version-Release number of selected component (if applicable):
nautilus-2.6.0-4

How reproducible:
Always.

Additional info:
Reported on x86_64 as I do not have two floppies on my i386 test
rig so I do not know if this reproducible there as well.
Comment 1 Michal Jaegermann 2004-05-11 18:48:22 EDT
Created attachment 100167 [details]
Resutls of starting nautilus with two floppies
Comment 2 Michal Jaegermann 2004-05-11 19:24:47 EDT
After changing /etc/fstab entries into

/dev/fd0                /mnt/floppy             auto    noauto,user 0 0
/dev/sda                /mnt/floppy1            auto    noauto,user 0 0

the second line is not removed with unplugging a USB floppy, hence
it is available again if replugged, but nautilus bombs out regardless
if a device itself is present or absent.
Comment 3 Michal Jaegermann 2004-05-11 20:51:46 EDT
I am slow today.  From comment #2 it follows that a presence of absence
of devices should be irrelevant and only a content of /etc/fstab
matters.  The bug seems to be indeed x86_64 specific.  Putting two
floppy entries in fstab, at least without a real hardware, does not
faze nautilus on i386 and it shows up "Floppy" and "Floppy 2" under
"Computer".
Comment 4 Mark Lane 2004-05-27 12:41:54 EDT
I talked with Michal and it seems that I may have the same problem 
with FC2. I have similar hardware. 
 
ASUS SK8V K8T800 Chipset. 
Opteron 142 
2x512MB PC3200 ECC Reg 
Fedora Core 2 running of an 80Gig WDJD off the VIA SATA Controller 
 
The only difference is that I have 2 Optical Devices and Michal had 
the 2 Floppy Devices. I have a 12xDVD and a CDRW. 
 
Just like with Michal's problem, nautilus crashes at startup. 
 
I have a trace on my system at home but I won't be able to access it 
until tonight at which time I will attach it. 
 
 
Comment 5 Mark Lane 2004-05-28 01:45:51 EDT
Created attachment 100651 [details]
This is the bug report bug buddy created including a trace.
Comment 6 Michal Jaegermann 2004-07-28 12:27:47 EDT
An update to ORBit2 which fixes bug #126181 apears to solve
that issue as well.  It would be good to hear what Mark has to
say on the matter.

With two floppies active and mounted somewhat humorous labels
show up in a Nautilus window.  Namely "Floppy: floppy" and
"Floppy 2: floppy1".  Likely I can find people which will be confused
by that.  Otherwise both floppies work so far.
Comment 7 Mark McLoughlin 2004-07-28 12:56:12 EDT
Yeah, looking at the trace it would make sense that this is the same
alignment issue. Thanks Michal

*** This bug has been marked as a duplicate of 126181 ***
Comment 8 Mark Lane 2004-07-29 10:02:36 EDT
I did test this and it seems to fix the problem with 2 CDROMs in
nautilus. Though my regular user still can't log into gnome. :(
Comment 9 Red Hat Bugzilla 2006-02-21 14:03:11 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.