Bug 1261950 - Set Action for icmp type needs to be writeable to support distributed icmp responder
Set Action for icmp type needs to be writeable to support distributed icmp re...
Status: CLOSED DUPLICATE of bug 1298550
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: openvswitch (Show other bugs)
7.3
All All
medium Severity medium
: rc
: 7.2
Assigned To: Flavio Leitner
qding
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-10 09:46 EDT by ffernand
Modified: 2017-01-18 02:03 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-13 18:31:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ffernand 2015-09-10 09:46:41 EDT
Description of problem:


irc #openvswitch

[15:59:14]  <marcelo-amaral> hi

[16:01:21]  <marcelo-amaral> I saw here: http://openvswitch.org/pipermail/discuss/2015-March/017097.html that OVS does not support yet modifying the type or code in ICMP. Is it still true?

[16:02:06]  <shettyg1> marcelo-amaral: True.

[16:02:56]  <marcelo-amaral> Is there any way to turn around this limitation?

[16:03:41]  <marcelo-amaral> I want to create of rules for ICMP reply

[16:03:54]  <shettyg1> Quick counter question. You want OVS to ICMP reply to you?

[16:04:36]  <shettyg1> I suppose this is for L3 router interface?

[16:05:49]  <marcelo-amaral> Yes, when we create a virtual router in openstack, the default gateway does not respond ping

[16:06:30]  <marcelo-amaral> So, it is required to create a specific rule to deal with it

[16:11:28]  <marcelo-amaral> shettygl: do you have any idea how I could create icmp reply? If it is possible

[16:24:03]  <marcelo-amaral> blp: hi

[16:24:21]  <blp> marcelo-amaral: hi

[16:25:54]  <marcelo-amaral> blp: I am trying to create a icmp reply rule, but I saw that OVS does not support yet modifying the type or code in ICMP. Do you now, if there is a way to do it, or if ovs will support it?

[16:30:12]  <blp> marcelo-amaral: It would not be hard to add, so we'd probably accept a patch to do it.

[16:30:29]  <blp> It would require some care in use, since a lot of ICMP types don't have compatible payloads.

[16:46:16]  <marcelo-amaral> blp: thank you, I will try to take a look in the code.

[16:49:28]  <marcelo-amaral> blp: could you please point in the code, where is it?

[16:49:50]  <blp> marcelo-amaral: Where is what?

[16:50:33]  <marcelo-amaral> blp: the logic that block modifying the type or code in ICMP

[16:50:46]  <jiuweigui> Hi. Are there any good book about openvswitch or sdns that you'd recommend?

[16:51:35]  <blp> marcelo-amaral: meta-flow.h, change access from read-only to read/write for those fields

[16:52:03]  <marcelo-amaral> blp: perfect! thank you very much

Additional info:

Reference links:

https://lists.opendaylight.org/pipermail/ovsdb-dev/2015-August/001780.html
http://openvswitch.org/pipermail/discuss/2015-March/017097.html

ODL bug that requires this change:
https://bugs.opendaylight.org/show_bug.cgi?id=4132
Comment 2 Flavio Leitner 2015-11-05 11:53:30 EST
This upstream thread implements the feature:
http://openvswitch.org/pipermail/dev/2015-November/061785.html
Comment 3 ffernand 2015-11-06 09:25:16 EST
OVS support for setting icmp type/code is in the works:
http://patchwork.ozlabs.org/patch/539643/
Comment 4 lpeer 2015-12-23 02:57:38 EST
fbl - can we get this patch in OVS 2.4? we need it to be able to pass scenario tests in OpenStack deployment (OSP-8) that is using ODL as the networking driver.
Comment 5 Flavio Leitner 2015-12-30 11:58:42 EST
(In reply to lpeer from comment #4)
> fbl - can we get this patch in OVS 2.4?

We plan to update to 2.5 very soon which includes the patch.
Does that work for you?
Comment 8 Flavio Leitner 2016-05-13 18:31:06 EDT

*** This bug has been marked as a duplicate of bug 1298550 ***

Note You need to log in before you can comment on or make changes to this bug.