Bug 1261956 - Storage pool version/domains format isn't reverted although no dc upgrade occurred
Storage pool version/domains format isn't reverted although no dc upgrade occ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.5.0
Unspecified Unspecified
unspecified Severity high
: ovirt-3.6.0-rc3
: 3.6.0
Assigned To: Liron Aravot
Natalie Gavrielov
: ZStream
Depends On:
Blocks: 1269471
  Show dependency treegraph
 
Reported: 2015-09-10 09:52 EDT by Liron Aravot
Modified: 2016-03-10 07:02 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1269471 (view as bug list)
Environment:
Last Closed: 2016-03-10 05:41:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 45931 master MERGED core: revert dc version if no update occured. Never
oVirt gerrit 46021 ovirt-engine-3.6 MERGED core: revert dc version if no update occured. Never
oVirt gerrit 46029 ovirt-engine-3.5 MERGED core: revert dc version if no update occured. Never
oVirt gerrit 47122 ovirt-engine-3.6.0 MERGED core: revert dc version if no update occured. Never

  None (edit)
Description Liron Aravot 2015-09-10 09:52:12 EDT
Description of problem:
When failing to upgrade the storage pool the engine can revert back the updated db in case it's known that no upgrade occured.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Create A DC with one host and 2 domains.
2. Move host to maintenance
3. Block connection to the non master domain
4. Activate the host
5. The host becomes the SPM
6. Attempt to upgrade the storage pool.

Actual results:
An error will appear in the logs indicating that upgrade can't be done because
there's a pool upgrade in progress

Expected results:
If we know that no update occurred, the changes can be safely rolled back.

Additional info:
Comment 2 Natalie Gavrielov 2015-11-17 10:43:47 EST
Verification steps (basically, same as issue #1269471):

1. Create a 3.5 DC with one host and 2 domains: iSCSI as data master, and NFS as data.
2. Move the host to maintenance.
3. Block connection to the NFS data domain (not the master), using: iptables -A OUTPUT -d IP_ADDRESS_OF_NFS_STORAGE_DOMAIN -j DROP.
4. Activate host (wait for it to become the SPM).
5. Upgrade Cluster to 3.6.
6. Upgrade DC to 3.6.

Results (From audit):

Nov 17, 2015 5:04:20 PM Data Center 35_DC was updated by admin@internal
Nov 17, 2015 5:04:20 PM Data Center 35_DC has encountered problems during upgrade process.

engine.log:

2015-11-17 17:04:20,733 ERROR [org.ovirt.engine.core.vdsbroker.irsbroker.UpgradeStoragePoolVDSCommand] (org.ovirt.thread.pool-7-thread-28) [6ba37206] Command 'UpgradeStoragePoolVDSCommand( UpgradeStoragePoolVDSCommandParameters:{runAsync='true', storagePoolId='fb8084e3-95a7-4dba-bb23-ee96deca2e54', ignoreFailoverLimit='false', storagePoolId='fb8084e3-95a7-4dba-bb23-ee96deca2e54', poolVersion ='3'})' execution failed: IRSGenericException: IRSErrorException: Upgrading a pool while an upgrade is in process is unsupported (pool: `fb8084e3-95a7-4dba-bb23-ee96deca2e54`): ''

----------------------------------------------------------------------------
UI shows that the DC version stays 3.5 (as it should, since upgrade failed).
----------------------------------------------------------------------------

I saw that there is already a bug regarding the confusing messages in the audit log (issue #1279417)
Comment 3 Allon Mureinik 2016-03-10 05:41:00 EST
RHEV 3.6.0 has been released, setting status to CLOSED CURRENTRELEASE
Comment 4 Allon Mureinik 2016-03-10 05:46:17 EST
RHEV 3.6.0 has been released, setting status to CLOSED CURRENTRELEASE
Comment 5 Allon Mureinik 2016-03-10 07:02:49 EST
RHEV 3.6.0 has been released, setting status to CLOSED CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.