Bug 1269471 - Storage pool version/domains format isn't reverted although no dc upgrade occurred
Storage pool version/domains format isn't reverted although no dc upgrade occ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.5.0
Unspecified Unspecified
unspecified Severity unspecified
: ovirt-3.5.6
: 3.5.6
Assigned To: Liron Aravot
Aharon Canan
storage
: ZStream
Depends On: 1261956
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-07 08:10 EDT by rhev-integ
Modified: 2016-02-10 11:47 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1261956
Environment:
Last Closed: 2015-12-01 14:06:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 45931 master MERGED core: revert dc version if no update occured. Never
oVirt gerrit 46021 ovirt-engine-3.6 MERGED core: revert dc version if no update occured. Never
oVirt gerrit 46029 ovirt-engine-3.5 MERGED core: revert dc version if no update occured. Never

  None (edit)
Comment 2 Aharon Canan 2015-11-08 11:41:32 EST
Not sure if the results are like expected -

Verification steps:
1. Created A 3.4 DC with one host and 2 domains (ISCSI and NFS).
2. Moved host to maintenance
3. Blocked connection to the non master domain (NFS)
4. Activated the host
5. The host became SPM
6. Attempt to upgrade the DC to 3.5

Results (From audit)-
=====================
2015-Nov-08, 18:28 Data Center DC was updated by admin@internal
2015-Nov-08, 18:28 Data Center DC has encountered problems during upgrade process.

Results (From engine.log)-
==========================
2015-11-08 18:28:33,954 ERROR [org.ovirt.engine.core.vdsbroker.irsbroker.UpgradeStoragePoolVDSCommand] (org.ovirt.thread.pool-7-thread-50) [2f32a3a] Command UpgradeStoragePoolVDSCommand( storagePoolId = 1826ad9b-62ab-4abd-a1e8-893599197bb9, poolVersion = 3) execution failed. Exception: IrsOperationFailedNoFailoverException: IRSGenericException: IRSErrorException: Upgrading a pool while an upgrade is in process is unsupported (pool: `1826ad9b-62ab-4abd-a1e8-893599197bb9`): ''



So, 
The DC remains 3.4 (makes sense). Error still appears in engine logs (bug says it shouldn't), in Audit logs it seems the DC was updated (where it didn't)

Please advice.
Comment 3 Allon Mureinik 2015-11-09 07:06:49 EST
The DC indeed should not be updated. The error in the log is OK IMHO - an error actually occurred, and we'd want to have the information on what happened.

The audit log should be fixed though so it doesn't mislead the user. Probably something like:

- Started DC Upgrade for DC xyz
- DC Upgrade for DC xyz failed/succeeded.
Comment 4 Aharon Canan 2015-11-09 07:31:03 EST
Verified using vt18.2 (Comment #2)

new bug for audit log (following comment #3) - https://bugzilla.redhat.com/show_bug.cgi?id=1279417
Comment 6 errata-xmlrpc 2015-12-01 14:06:16 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2531.html

Note You need to log in before you can comment on or make changes to this bug.