Bug 1261970 - rebase python-oslo-utils to >= 1.6.0 [NEEDINFO]
rebase python-oslo-utils to >= 1.6.0
Status: CLOSED CANTFIX
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-oslo-utils (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
medium Severity unspecified
: z3
: 7.0 (Kilo)
Assigned To: Jon Schlueter
yeylon@redhat.com
: Rebase, Triaged, ZStream
Depends On:
Blocks: 1252954
  Show dependency treegraph
 
Reported: 2015-09-10 10:16 EDT by Pradeep Kilambi
Modified: 2016-04-18 02:52 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-16 17:13:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
jschluet: needinfo? (pkilambi)


Attachments (Terms of Use)

  None (edit)
Description Pradeep Kilambi 2015-09-10 10:16:07 EDT
As per $Subject please rebase as gnocchi 1.1 requires it
Comment 5 Lon Hohberger 2015-09-10 12:33:53 EDT
Current version is 1.4.0.  This would need to pass regression testing.
Comment 6 Jon Schlueter 2015-09-10 14:11:13 EDT
fedora/f23 had 1.4.0 as last packaged
fedora/master had 1.6.0 for a little while and is currently at 2.4.0 which added python-monotonic at 2.2.0 

looks like 1.6.0 might pull in pytz and python-debtcollector Requires
Comment 9 Jon Schlueter 2015-09-14 12:26:02 EDT
oslo-utils can not be upgraded to 1.6.0 stable/kilo branch upstream is 1.4.0 + 3 patches right now and for OSP 7 we can't go past stable/kilo

If there are patches that are needed then we can work to get those backported and accepted to oslo-utils stable/kilo branch and then tagged to support this effort.

What is needed now is to look at what is breaking/blocked by using 1.4.0 or stable/kilo branch for OSP7.
Comment 11 hguemar 2015-09-19 16:00:57 EDT
For oslo libs updates, I suggest that we check global requirements first, it saves a lot of time. oslo.utils < 1.5.0 for Kilo

https://github.com/openstack/requirements/blob/stable/kilo/global-requirements.txt#L73

Note You need to log in before you can comment on or make changes to this bug.