Bug 1262070 - [RFE] Configure Ceph RBD as Cinder Backap target in RHEL-OSP director
[RFE] Configure Ceph RBD as Cinder Backap target in RHEL-OSP director
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: puppet-tripleo (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
medium Severity unspecified
: rc
: 10.0 (Newton)
Assigned To: John Fulton
Yogev Rabl
: FutureFeature, Triaged
Depends On: 1262064
Blocks: 1387078
  Show dependency treegraph
 
Reported: 2015-09-10 14:39 EDT by Sean Cohen
Modified: 2017-01-05 01:33 EST (History)
12 users (show)

See Also:
Fixed In Version: puppet-tripleo-5.0.0-0.20160907223204.488fb91.el7ost
Doc Type: Enhancement
Doc Text:
You can now use the director to configure Ceph RBD as a Block Storage backup target. This will allow you to deploy an overcloud where volumes are set to back up to a Ceph target. By default, volume backups will be stored in a Ceph pool called 'backups'. Backup settings are configured in the following environment file (on the undercloud): /usr/share/openstack-tripleo-heat-templates/environments/cinder-backup.yaml
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-12-14 10:15:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
scohen: needinfo+


Attachments (Terms of Use)
Steps vollowed to verify this feature is working (6.05 KB, text/plain)
2016-10-24 10:50 EDT, John Fulton
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 311218 None None None 2016-09-07 16:46 EDT
OpenStack gerrit 329041 None None None 2016-09-07 16:53 EDT

  None (edit)
Description Sean Cohen 2015-09-10 14:39:43 EDT
Allow to configure Ceph RBD as Cinder Backap target in RHEL-OSP director for RBD to RBD incremental backups (
Comment 5 Mike Burns 2016-04-07 16:50:54 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 11 John Fulton 2016-10-24 10:50 EDT
Created attachment 1213494 [details]
Steps vollowed to verify this feature is working

I tested this feature with OSP10 puddle 2016-10-20.5 and it worked. Attaching steps I followed to test it.
Comment 13 Yogev Rabl 2016-11-07 07:29:48 EST
verified on puppet-tripleo-5.3.0-4.el7ost.noarch
Comment 14 John Fulton 2016-11-18 10:03:10 EST
cinder-backup.yaml
Comment 16 errata-xmlrpc 2016-12-14 10:15:24 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html

Note You need to log in before you can comment on or make changes to this bug.