Bug 1262064 - [RFE] Expose Cinder Backup in RHEL-OSP director
[RFE] Expose Cinder Backup in RHEL-OSP director
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
urgent Severity medium
: beta
: 10.0 (Newton)
Assigned To: Giulio Fidente
lkuchlan
: AutomationBlocker, FutureFeature, Triaged
: 1254938 1293875 (view as bug list)
Depends On:
Blocks: 1262070
  Show dependency treegraph
 
Reported: 2015-09-10 14:28 EDT by Sean Cohen
Modified: 2016-12-14 10:15 EST (History)
17 users (show)

See Also:
Fixed In Version: openstack-tripleo-heat-templates-5.0.0-0.20160907212643.90c852e.2.el7ost
Doc Type: Enhancement
Doc Text:
Feature: It is not possible to deploy 'cinder-backup' in the overcloud using a Heat environment file when launching the stack deployment. The environment file which enables 'cinder-backup' is /usr/share/openstack-tripleo-heat-templates/environments/cinder-backup.yaml The 'cinder-backup' service will initially support the use of Swift or Ceph as backends. Reason: The 'cinder-backup' service performs backups of Cinder volumes on backends different than the one where the volumes are stored. Result: The 'cinder-backup' service will be running in the overcloud if included at deployment time.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-12-14 10:15:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 304563 None None None 2016-07-19 08:59 EDT
OpenStack gerrit 311218 None None None 2016-05-04 06:57 EDT

  None (edit)
Description Sean Cohen 2015-09-10 14:28:14 EDT
Currently we do not expose the Cinder backup capability in director.

As an admin, I need to ensure that all of my users’ data is backed up in case of accidental deletion where restoration is a manual process.

As a user, I want access to backups of all my Cinder Volumes and snapshots.


See https://github.com/openstack/puppet-cinder/blob/master/manifests/backup.pp
Comment 3 Sean Cohen 2015-10-07 09:29:40 EDT
*** Bug 1254938 has been marked as a duplicate of this bug. ***
Comment 5 Emilien Macchi 2015-12-01 16:59:04 EST
which backend are we going use? Swift or RBD?
Comment 9 Evgeny 2016-02-03 07:33:56 EST
*** Bug 1293875 has been marked as a duplicate of this bug. ***
Comment 11 Mike Burns 2016-04-07 16:50:54 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 13 Giulio Fidente 2016-08-11 15:01:58 EDT
The existing submissions will configure backup service in pacemaker so that there is always a single instance running, like volume, not colocated with volume service though. Backend can be either Swift or Ceph.
Comment 15 lkuchlan 2016-10-10 07:46:36 EDT
Tested using:
openstack-tripleo-heat-templates-5.0.0-0.20161003064637.d636e3a.1.1.el7ost.noarch

Verification flow:
[root@controller-0 ~]# systemctl status openstack-cinder-backup | grep active
Active: active (running) since Mon 2016-10-10 10:15:14 UTC; 1h 22min ago

[stack@undercloud-0 ~]$ cinder create 1
+--------------------------------+--------------------------------------+
| Property                       | Value                                |
+--------------------------------+--------------------------------------+
| attachments                    | []                                   |
| availability_zone              | nova                                 |
| bootable                       | false                                |
| consistencygroup_id            | None                                 |
| created_at                     | 2016-10-10T11:38:25.000000           |
| description                    | None                                 |
| encrypted                      | False                                |
| id                             | 6a87140b-4c91-4854-9de6-1ca5e00ffee5 |
| metadata                       | {}                                   |
| migration_status               | None                                 |
| multiattach                    | False                                |
| name                           | None                                 |
| os-vol-host-attr:host          | None                                 |
| os-vol-mig-status-attr:migstat | None                                 |
| os-vol-mig-status-attr:name_id | None                                 |
| os-vol-tenant-attr:tenant_id   | 34a8fb398a6542398085c3f29f8676d3     |
| replication_status             | disabled                             |
| size                           | 1                                    |
| snapshot_id                    | None                                 |
| source_volid                   | None                                 |
| status                         | creating                             |
| updated_at                     | None                                 |
| user_id                        | c1400d1b3f16466da0d94b53eb5c3471     |
| volume_type                    | None                                 |
+--------------------------------+--------------------------------------+
[stack@undercloud-0 ~]$ cinder backup-create 6a87140b-4c91-4854-9de6-1ca5e00ffee5
+-----------+--------------------------------------+
| Property  | Value                                |
+-----------+--------------------------------------+
| id        | 9f0e816b-1614-4541-a66f-6307a0a5367e |
| name      | None                                 |
| volume_id | 6a87140b-4c91-4854-9de6-1ca5e00ffee5 |
+-----------+--------------------------------------+

[stack@undercloud-0 ~]$ cinder backup-list
+--------------------------------------+--------------------------------------+-----------+------+------+--------------+---------------+
| ID                                   | Volume ID                            | Status    | Name | Size | Object Count | Container     |
+--------------------------------------+--------------------------------------+-----------+------+------+--------------+---------------+
| 9f0e816b-1614-4541-a66f-6307a0a5367e | 6a87140b-4c91-4854-9de6-1ca5e00ffee5 | available | -    | 1    | 22           | volumebackups |
+--------------------------------------+--------------------------------------+-----------+------+------+--------------+---------------+

[stack@undercloud-0 ~]$ cinder list
+--------------------------------------+-----------+-----------------------------------------------------+------+-------------+----------+-------------+
| ID                                   | Status    | Name                                                | Size | Volume Type | Bootable | Attached to |
+--------------------------------------+-----------+-----------------------------------------------------+------+-------------+----------+-------------+
| ad72daee-cd90-4cca-8d60-3d3d95d2c9a5 | available | restore_backup_9f0e816b-1614-4541-a66f-6307a0a5367e | 1    | -           | false    |             |
+--------------------------------------+-----------+-----------------------------------------------------+------+-------------+----------+-------------+
Comment 18 errata-xmlrpc 2016-12-14 10:15:11 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html

Note You need to log in before you can comment on or make changes to this bug.