Bug 1262095 - [RFE] Aysnc RBD Mirroring
[RFE] Aysnc RBD Mirroring
Status: CLOSED ERRATA
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RBD (Show other bugs)
1.3.1
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 2.0
Assigned To: Jason Dillaman
Hemanth Kumar
Bara Ancincova
https://wiki.ceph.com/Planning/Bluepr...
: FutureFeature
Depends On:
Blocks: 1201698 1283413 1322504
  Show dependency treegraph
 
Reported: 2015-09-10 15:31 EDT by Sean Cohen
Modified: 2017-07-30 11:26 EDT (History)
8 users (show)

See Also:
Fixed In Version: ceph v10.2.0
Doc Type: Enhancement
Doc Text:
.Block Device mirroring is now supported The RADOS Block Device (RBD) mirroring feature has been added to the Red Hat Ceph Storage 2. RBD mirroring is a process of replicating Ceph Block Device images between two peer Ceph Storage Clusters. The mirroring is asynchronous, crash-consistent, and serves primarily for disaster recovery. To learn more about RBD mirroring, see the https://access.redhat.com/documentation/en/red-hat-ceph-storage/2/single/block-device-guide/#block_device_mirroring[Block Device Mirroring] chapter in the https://access.redhat.com/documentation/en/red-hat-ceph-storage/2/single/block-device-guide/[Block Device] guide for Red Hat Ceph Storage 2.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-23 15:26:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2838291 None None None 2017-01-25 15:49 EST

  None (edit)
Description Sean Cohen 2015-09-10 15:31:47 EDT
Overview
=======
Currently, to support disaster recovery for RBD, we advise that customers export/import each RBD as an image for copying between two distinct clusters. This is cumbersome with large numbers, requires a dedicated host to manage the files and can be slow for the initial copy. 
Async RBD Mirroring will allow each RBD to be streamed in realtime to a secondary cluster and be point in time consistent. This feature is roughly equivalent to NetApp's SnapMirror in purpose.

User Stories:
==========
* As an administrator, I select a pool's RBD contents to be asynchronously mirrored to a pool in a second RADOS cluster.
* As an administrator, I select an individual RBD to be asynchronously mirrored to a pool in a second RADOS cluster.
* As an administrator, I can see which pools or RBDs are successfully being mirrored to a secondary cluster.
* As an administrator, I am warned when a pool or RBD is not being successfully mirrored to a secondary cluster.
* As an administrator, I can pause mirroring for a pool or RBD.
Comment 6 Ken Dreyer (Red Hat) 2015-12-11 13:41:59 EST
There will be a new daemon "rbd-mirror" that runs on a separate server, similar to how we isolate RGW on its own node(s). It is essentially a client to the cluster, so same constraints as RGW.
Comment 10 Jason Dillaman 2016-05-02 15:53:17 EDT
Looks good to me -- only minor comment is perhaps mention that it is asynchronous and crash consistent mirroring?
Comment 13 errata-xmlrpc 2016-08-23 15:26:36 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1755

Note You need to log in before you can comment on or make changes to this bug.