Bug 1283413 - [RFE][cinder] RBD Cinder Volume Replication driver
[RFE][cinder] RBD Cinder Volume Replication driver
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
high Severity medium
: Upstream M2
: 11.0 (Ocata)
Assigned To: Jon Bernard
Tzach Shefi
Don Domingo
https://blueprints.launchpad.net/cind...
upstream_milestone_ocata-2 upstream_d...
: FutureFeature, TechPreview, Triaged
: 1201698 (view as bug list)
Depends On: 1262095 1365648
Blocks: 1317347 1201698 1262100 1335682
  Show dependency treegraph
 
Reported: 2015-11-18 16:58 EST by Sean Cohen
Modified: 2017-05-17 15:24 EDT (History)
17 users (show)

See Also:
Fixed In Version: openstack-cinder-10.0.0-0.20170106133027.458153d.el7ost
Doc Type: Technology Preview
Doc Text:
The Ceph volume driver now includes RBD replication, which provides replication capabilities at the cluster level. This feature allows you to set a secondary Ceph cluster as a replication device; replicated volumes are then mirrored to this device. During failover, all replicated volumes are set to 'primary', and all new requests for those volumes will be redirected to the replication device. To enable this feature, use the parameter replication_device to specify a cluster that the Ceph back end should mirror to. This feature requires both primary and secondary Ceph clusters to have RBD mirroring set up between them. For more information, see http://docs.ceph.com/docs/master/rbd/rbd-mirroring/. At present, RBD replication does not feature a failback mechanism. In addition, the freeze option does not work as described, and replicated volumes are not automatically attached/detached to the same instance during failover.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-05-17 15:24:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
scohen: needinfo+
scohen: needinfo+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 333565 None None None 2016-07-08 10:52 EDT
OpenStack gerrit 411967 None None None 2017-01-04 08:52 EST

  None (edit)
Description Sean Cohen 2015-11-18 16:58:01 EST
Expose Ceph RBD Mirroring via Cinder Replication API v2
Comment 3 Sean Cohen 2016-08-16 11:46:36 EDT
*** Bug 1201698 has been marked as a duplicate of this bug. ***
Comment 4 Elise Gafford 2016-08-22 14:48:14 EDT
Moving to ON_DEV, as this change is currently under upstream review but has not yet been merged.
Comment 5 Paul Grist 2016-09-06 16:41:12 EDT
Just a status update, Work is continuing on this one with the goal of an FFE for Newton.
Comment 17 Tzach Shefi 2017-03-26 10:24:48 EDT
These are the bugs I found so far, ran 5 test cases out of ~16.

https://bugzilla.redhat.com/show_bug.cgi?id=1435962
https://bugzilla.redhat.com/show_bug.cgi?id=1435969
https://bugzilla.redhat.com/show_bug.cgi?id=1435984
https://bugzilla.redhat.com/show_bug.cgi?id=1435996

Currently waiting for Dev assistance. 
My system has been #cinder failover-host (part of test case) it's now stuck. 

As there isn't (yet) any #cinder failback host 
command I can't restore initial system state. 
I need this as I have a more test cases which involve Cinder failover. 

I'll update RFE status once I get more test cases done.
Comment 21 Tzach Shefi 2017-03-29 14:13:13 EDT
Verified as tech preview. 
openstack-cinder-10.0.1-0.20170310192919.b05afc3.el7ost.noarch

Critical positive work flow test cases passed.
Create\delete a replicated volume and attach to instance post failover. 
 
Opened new bugs: 1435962  1435969 1435984 1435996. 
Jon will add a few more bugs from his side.
Comment 23 errata-xmlrpc 2017-05-17 15:24:38 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245

Note You need to log in before you can comment on or make changes to this bug.