Bug 1262107 - When sorting by instance size, it's not sorted the right way
When sorting by instance size, it's not sorted the right way
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
6.0 (Juno)
Unspecified Unspecified
unspecified Severity low
: ---
: 6.0 (Juno)
Assigned To: Alvaro Lopez Ortega
Ido Ovadia
: Triaged, ZStream
Depends On:
Blocks: 1292734
  Show dependency treegraph
 
Reported: 2015-09-10 16:02 EDT by David Hill
Modified: 2018-02-08 05:55 EST (History)
8 users (show)

See Also:
Fixed In Version: python-django-horizon-8.0.0-9.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1292734 (view as bug list)
Environment:
Last Closed: 2016-12-05 09:39:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1518893 None None None Never

  None (edit)
Description David Hill 2015-09-10 16:02:13 EDT
Description of problem:
When displaying the instance list of a project in the Horizon dashboard((http://public_vip/dashboard/project/instances/)) and sorting the instances by the "Size" column, it won't be sorted the right way.

Version-Release number of selected component (if applicable):
Juno

How reproducible:
Always

Steps to Reproduce:
1. Create many instances of different sizing
2. Go to (http://public_vip/dashboard/project/instances/)
3. Play with the "Size" column sorting until you notice the sorting failure

Actual results:
m1.tiny
m1.small
m1.medium
m1.small

Expected results:
m1.tiny
m1.small
m1.small
m1.medium

Additional info:
All the other columns sorting funcitonnality seems to be working fine
Comment 3 Matthias Runge 2015-10-15 02:09:04 EDT
What would you expect here and why?
Ordered by alphabetical order? RAM? CPU? combination of both? disk space?

Your expected order lists m1.small twice, what's the difference between?
Comment 4 David Hill 2015-10-15 11:42:14 EDT
I can see this issue myself in the lab and I expect to have at least the m1.medium to be at the end or the beginning of the list but not in between two m1.small instances like illustrated below:


Actual results:
m1.tiny
m1.small
m1.medium
m1.small

Expected results:
m1.tiny
m1.small
m1.small
m1.medium
Comment 5 Matthias Runge 2015-10-16 04:03:18 EDT
Could you please answer the question, how your two m1.small instances differ?
Comment 6 David Hill 2015-10-16 21:03:04 EDT
They don't... they are exactly the same.   I created 4 instances that uses the same flavor when they are the same.

nova boot --flavor m1.small --image rhel6 --nic net-id=b0038c80-8082-4a9c-a556-ef5c9aecb4fa test-dave
nova boot --flavor m1.small --image rhel6 --nic net-id=b0038c80-8082-4a9c-a556-ef5c9aecb4fa test-dave2
nova boot --flavor m1.tiny --image rhel6 --nic net-id=b0038c80-8082-4a9c-a556-ef5c9aecb4fa test-dave3
nova boot --flavor m1.medium --image rhel6 --nic net-id=b0038c80-8082-4a9c-a556-ef5c9aecb4fa test-dave4
Comment 9 Itxaka 2015-12-15 06:48:04 EST
Fix has been merged, will be available on 9
Comment 16 Mike McCune 2016-03-28 18:44:25 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 18 Radomir Dopieralski 2016-12-05 09:39:02 EST
This has been fixed and all the backports merged a long time ago.

Note You need to log in before you can comment on or make changes to this bug.