Bug 1292734 - When sorting by instance size, it's not sorted the right way
When sorting by instance size, it's not sorted the right way
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
medium Severity low
: ---
: 7.0 (Kilo)
Assigned To: Radomir Dopieralski
Ola Pavlenko
: TestOnly, Triaged, ZStream
Depends On: 1262107
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-18 03:47 EST by Matthias Runge
Modified: 2017-06-29 10:11 EDT (History)
8 users (show)

See Also:
Fixed In Version: python-django-horizon-2015.1.3-1.el7ost
Doc Type: Bug Fix
Doc Text:
Cause: Sorting of flavors doesn't make sense Consequence: Fix: Sorting was removed from flavor column Result: Horizon does not provide the false claim any more, that sorting by flavor makes any sense.
Story Points: ---
Clone Of: 1262107
Environment:
Last Closed: 2017-06-29 10:11:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1518893 None None None 2015-12-18 03:47 EST

  None (edit)
Comment 1 Matthias Runge 2016-06-14 03:31:12 EDT
According to our records, this has already been shipped.
Comment 2 Lon Hohberger 2016-06-23 14:20:59 EDT
According to our records, this should be resolved by python-django-horizon-2015.1.4-1.el7ost.  This build is available now.
Comment 4 Ido Ovadia 2016-07-26 11:32:56 EDT
Failed QA
=========
Failed on: python-django-horizon-2015.1.4-1.el7ost.noarch

How Reproduced:
===============
1. Create many instances of different size (flavors)
2. Go to (http://public_vip/dashboard/project/instances/)
3. Play with the "Size" column sorting until you notice the sorting failure

Actual results:
===============
Instances don't sort, it seems that the sorting is missing on this column 

Expected results:
=================
Instances sort by size

==============================================
Test 2:
=======
1. Create many instances of different size (flavors)
2. Go to (http://public_vip/dashboard/admin/instances/)
3. Play with the "Size" column sorting until you notice the sorting failure

Actual results:
===============
m1.tiny
m1.tiny
m1.tiny
m1.medium
m1.small

Expected results:
=================
m1.tiny
m1.tiny
m1.tiny
m1.small
m1.medium
Comment 5 Matthias Runge 2016-07-27 02:39:07 EDT
That's actually the issue with this bug.

No sorting makes sense here, there are way too many variables (cpu, ram, disk, ...)
It shouldn't be sortable. if it is, that's actually the bug.

In my tests, in projects/instances, the size attribute is not sortable.
Comment 6 Beth Elwell 2017-06-29 10:11:22 EDT
As above comment, the flavor column is not sortable due to the number of variables involved. This table does not have a size column.

Note You need to log in before you can comment on or make changes to this bug.