This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1262117 - [RFE] Swift Object Versioning support
[RFE] Swift Object Versioning support
Status: CLOSED ERRATA
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW (Show other bugs)
1.3.1
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 2.2
Assigned To: Yehuda Sadeh
shilpa
Bara Ancincova
: Reopened
Depends On:
Blocks: 1412948
  Show dependency treegraph
 
Reported: 2015-09-10 16:20 EDT by Neil Levine
Modified: 2017-07-30 11:54 EDT (History)
11 users (show)

See Also:
Fixed In Version: RHEL: ceph-10.2.5-7.el7cp Ubuntu: ceph_10.2.5-3redhat1xenial
Doc Type: Enhancement
Doc Text:
.The Ceph Object Gateway now supports the Swift object versioning The Ceph Object Gateway now supports the Swift object versioning APIs, including correct handling of the `X-Versions-Location` header. The `X-History-Location` header is not supported. The object versioning is an object-native version control mechanism of Swift object storage, and is a required capability for RefStack conformance. For details, see the https://docs.openstack.org/developer/swift/overview_object_versioning.html[Object Versioning] section of the OpenStack documentation.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-14 11:43:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Ceph Project Bug Tracker 15925 None None None 2016-09-19 07:07 EDT
Ceph Project Bug Tracker 8221 None None None 2016-09-19 07:07 EDT

  None (edit)
Description Neil Levine 2015-09-10 16:20:58 EDT
Implement Swift object versioning, which is different to S3 versioning, in RGW
Comment 2 Neil Levine 2015-09-23 14:57:26 EDT

*** This bug has been marked as a duplicate of bug 1262118 ***
Comment 3 Neil Levine 2015-10-02 16:30:24 EDT
No idea why I marked this as a dup so reopening.
Comment 7 Ken Dreyer (Red Hat) 2017-01-09 12:07:35 EST
From the upstream tickets, this feature looks ready in Ceph v10.2.5 upstream (the version we intend to ship in RH Ceph Storage 2.2). Is that right Yehuda?
Comment 8 Yehuda Sadeh 2017-01-09 12:28:36 EST
yes
Comment 9 Matt Benjamin (redhat) 2017-01-11 08:52:41 EST
(In reply to Yehuda Sadeh from comment #8)
> yes

ok, devel acked
Comment 16 shilpa 2017-02-28 05:10:21 EST
Looks good to me.
Comment 18 errata-xmlrpc 2017-03-14 11:43:28 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0514.html

Note You need to log in before you can comment on or make changes to this bug.