Bug 1262132 - Corsair K70 keyboard 'pipe' key not functioning correctly
Corsair K70 keyboard 'pipe' key not functioning correctly
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
22
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: 1262133
  Show dependency treegraph
 
Reported: 2015-09-10 17:56 EDT by Jacob Hunt
Modified: 2015-09-30 04:51 EDT (History)
11 users (show)

See Also:
Fixed In Version: 222-4.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1262133 (view as bug list)
Environment:
Last Closed: 2015-09-21 02:33:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jacob Hunt 2015-09-10 17:56:08 EDT
Description of problem:

When using the Corsair K70 keyboard and using the 'pipe' key and two 'pipe' symbols are displayed

Version-Release number of selected component (if applicable):

systemd-219-21.fc22.x86_64

How reproducible:

90%

Steps to Reproduce:
1. type a command using '|' key


Actual results:

cat foo | | grep bar

Expected results:

cat foo | grep bar

Additional info:

Adding the following to /lib/udev/hwdb.d/60-keyboard.hwdb resolves the issue.

# Corsair K70 keyboard
#keyboard:name:*Corsair*:dmi:bvn*:bvr*:bd*:svn*:pn*:pvr*
keyboard:usb:v1B1Cp1B09*
 KEYBOARD_KEY_70032=reserved
Comment 1 Jan Synacek 2015-09-11 02:57:06 EDT
https://github.com/systemd/systemd/issues/1243
Comment 2 Martin Pitt 2015-09-14 03:30:32 EDT
https://github.com/systemd/systemd/pull/1259 has a proposed fix for the current systemd hwdb syntax. Would be great if you could test this on a recent version (221 or later).
Comment 5 Fedora Update System 2015-09-14 09:02:57 EDT
systemd-219-24.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-15821
Comment 6 Fedora Update System 2015-09-15 01:55:22 EDT
systemd-219-24.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update systemd'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-15821
Comment 7 Fedora Update System 2015-09-16 17:20:09 EDT
systemd-219-24.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 8 gerrit.boesebeck 2015-09-17 09:42:53 EDT
Hi,

bad Fix. On a german keyboard layout the #-key won´t work with the Fix. 
KEYBOARD_KEY_70032 is the "#" and "'" Key
Comment 9 Fedora Update System 2015-09-18 08:39:55 EDT
systemd-222-3.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-16155
Comment 10 Fedora Update System 2015-09-18 10:46:09 EDT
systemd-222-4.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-16165
Comment 11 Fedora Update System 2015-09-18 20:20:30 EDT
systemd-222-4.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update systemd'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-16165
Comment 12 Fedora Update System 2015-09-23 00:08:01 EDT
systemd-222-4.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 13 Ali 2015-09-28 05:01:11 EDT
I just upgraded to systemd-219-24.fc22 and the hash '#' and tilde '~' key stopped working.  I'm using a united kingdom layout.  Bad fix guys.
Comment 14 Benjamin Salchow 2015-09-29 17:28:09 EDT
Hello,
I've tested it on one Fedora 22 PC and on two different Fedora 22 Notebooks and with the Corsair K70R keyboard (German layout) - Key # and ' didn't work after upgrade to systemd-219-24.fc22 on all of this Fedora 22 instances.
No Events are generated (showkey) at any time. Even no "Key undefined"-messages.
I've tried other Keyboards too, and they worked like a charm. I'm not sure where the error is located. The Corsair K70R keyboard works fine with other Linux Distributions (Debian 6 / Ubuntu 14.04) and Windows.
Please let me know if I could provide any Log or other information that will support you by fixing that problem.
Thank you very much,
Benny
Comment 15 Martin Pitt 2015-09-30 01:51:33 EDT
Note that the originally proposed patch was a bit unclear to begin with, and as it caused regressions it was reverted upstream the next day. From udev's point of view this is rather unfixable -- it's either some weird kind of hardware bug or a bug in the kernel driver for that keyboard.
Comment 16 Benjamin Salchow 2015-09-30 04:51:05 EDT
Yes, that's really not easy to fix in that case. Perhaps the kernel driver team could take a look how to handle that "sometimes double event"-Problem from the US-Keybord, the others Layouts don't show this behavior.

I'm using the latest firmware of this keyboard since a year and with an downgrade of systemd everything is working like it should. I never got double characters (in my case # ).
Wondering if Jacob Hunt is using the latest firmware of it. It's only possible to upgrade the Keybord Firmware with a Windows instance.  
Corsair Gaming K70 (non-RGB), Vengeance K70 	Firmware and documentation 	Firmware 1.09, Software 1.3 	09/19/2013
http://softwaredownloads.corsair.com/Files/Gaming-Keyboards/K70-setup-091913.zip
Did Jacob Hunt test it on a different PC or Distro, perhaps it's a HW bug by resending double character in 90 % of the cases.
Thanks for your answer,
Benny

Note You need to log in before you can comment on or make changes to this bug.