Bug 1262133 - Corsair K70 keyboard 'pipe' key not functioning correctly
Summary: Corsair K70 keyboard 'pipe' key not functioning correctly
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: systemd
Version: 7.2
Hardware: All
OS: Linux
unspecified
low
Target Milestone: rc
: ---
Assignee: systemd-maint
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On: 1262132
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-09-10 22:00 UTC by Jacob Hunt
Modified: 2016-11-23 09:07 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 1262132
Environment:
Last Closed: 2016-11-23 09:07:28 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jacob Hunt 2015-09-10 22:00:44 UTC
+++ This bug was initially created as a clone of Bug #1262132 +++

Description of problem:

When using the Corsair K70 keyboard and using the 'pipe' key and two 'pipe' symbols are displayed

Version-Release number of selected component (if applicable):

systemd-219-13.el7.x86_64

How reproducible:

90%

Steps to Reproduce:
1. type a command using '|' key


Actual results:

cat foo | | grep bar

Expected results:

cat foo | grep bar

Additional info:

Adding the following to /lib/udev/hwdb.d/60-keyboard.hwdb resolves the issue.

# Corsair K70 keyboard
#keyboard:name:*Corsair*:dmi:bvn*:bvr*:bd*:svn*:pn*:pvr*
keyboard:usb:v1B1Cp1B09*
 KEYBOARD_KEY_70032=reserved

Comment 2 Jan Synacek 2015-09-21 06:34:50 UTC
Note that the fix in the original bugzilla is not perfect. See https://bugzilla.redhat.com/show_bug.cgi?id=1262132#c8.

Comment 3 Jan Synacek 2016-11-23 09:07:28 UTC
The original fix was accepted upstream but later reverted. See https://bugzilla.redhat.com/show_bug.cgi?id=1262132#c16 and https://github.com/systemd/systemd/issues/1243.


Note You need to log in before you can comment on or make changes to this bug.