Bug 1262328 - "systemctl edit some.service" is broken
"systemctl edit some.service" is broken
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
22
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Synacek
Fedora Extras Quality Assurance
:
: 1262329 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-11 08:28 EDT by klingt.net
Modified: 2015-09-16 17:20 EDT (History)
7 users (show)

See Also:
Fixed In Version: 219-24.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-16 17:20:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description klingt.net 2015-09-11 08:28:47 EDT
Description of problem:

Calling `systemctl edit some.service`, after upgrading systemd on my fedora-22 droplet to release `23.fc22`` will result in the following error message:

```
Failed to execute vim: Bad address
editor failed with error code 1.
```

`strace systemctl edit some.service | grep vim` gives the following hint:

```
ioctl(1, TCGETS, 0x7ffebaecd410)        = -1 ENOTTY (Inappropriate ioctl for device)
writev(2, [{"Cannot edit units if not on a tt"..., 33}, {"\n", 1}], 2Cannot edit units if not on a tty
) = 34
```

Version-Release number of selected component (if applicable):

23.fc22

How reproducible:

(replace `some.service` with an existing service name)

Steps to Reproduce:
1. systemctl edit some.service

Actual results:


Expected results:


Additional info:

`uname -a`: Linux klingt.net 4.1.6-200.fc22.x86_64 #1 SMP Mon Aug 17 19:54:31 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
Comment 1 Zbigniew Jędrzejewski-Szmek 2015-09-11 10:09:15 EDT
*** Bug 1262329 has been marked as a duplicate of this bug. ***
Comment 2 klingt.net 2015-09-11 10:17:28 EDT
Quickfix: install the previous version with: `dnf downgrade systemd --allowerasing`
Comment 3 Jan Synacek 2015-09-14 05:34:36 EDT
Yes, it looks that I messed up the backport. Fix incoming.
Comment 5 Fedora Update System 2015-09-14 09:02:59 EDT
systemd-219-24.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-15821
Comment 6 Fedora Update System 2015-09-15 01:55:24 EDT
systemd-219-24.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update systemd'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-15821
Comment 7 Fedora Update System 2015-09-16 17:20:11 EDT
systemd-219-24.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.