Bug 1262329 - "systemctl edit some.service" is broken
"systemctl edit some.service" is broken
Status: CLOSED DUPLICATE of bug 1262328
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
22
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-11 08:28 EDT by klingt.net
Modified: 2015-09-11 10:09 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-11 10:09:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description klingt.net 2015-09-11 08:28:58 EDT
Description of problem:

Calling `systemctl edit some.service`, after upgrading systemd on my fedora-22 droplet to release `23.fc22`` will result in the following error message:

```
Failed to execute vim: Bad address
editor failed with error code 1.
```

`strace systemctl edit some.service | grep vim` gives the following hint:

```
ioctl(1, TCGETS, 0x7ffebaecd410)        = -1 ENOTTY (Inappropriate ioctl for device)
writev(2, [{"Cannot edit units if not on a tt"..., 33}, {"\n", 1}], 2Cannot edit units if not on a tty
) = 34
```

Version-Release number of selected component (if applicable):

23.fc22

How reproducible:

(replace `some.service` with an existing service name)

Steps to Reproduce:
1. systemctl edit some.service

Actual results:


Expected results:


Additional info:

`uname -a`: Linux klingt.net 4.1.6-200.fc22.x86_64 #1 SMP Mon Aug 17 19:54:31 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
Comment 1 Zbigniew Jędrzejewski-Szmek 2015-09-11 10:09:15 EDT

*** This bug has been marked as a duplicate of bug 1262328 ***

Note You need to log in before you can comment on or make changes to this bug.