Bug 1262361 - after installation can't login as root
after installation can't login as root
Status: CLOSED DUPLICATE of bug 1260875
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-11 09:36 EDT by Richard S. Hendershot
Modified: 2015-09-11 09:37 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-11 09:37:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard S. Hendershot 2015-09-11 09:36:08 EDT
Description of problem: root user password is created in plain-text by installation


Version-Release number of selected component (if applicable):


How reproducible:  always


Steps to Reproduce:
1. mount images/boot.iso (11-Sep) in vbox VM and perform installation
2. on completion root login fails. reboot using rw init=/bin/bash
3. grep root /etc/shadow

Actual results:  password is a star


Expected results: password field should be an encrypted value of that supplied during installation


Additional info:  useradd creates user with plain-text password
Comment 1 David Shea 2015-09-11 09:37:07 EDT

*** This bug has been marked as a duplicate of bug 1260875 ***

Note You need to log in before you can comment on or make changes to this bug.