Bug 1260875 - Cannot log in as root after install of recent Fedora 23 images
Cannot log in as root after install of recent Fedora 23 images
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
23
All All
urgent Severity urgent
: ---
: ---
Assigned To: David Shea
Fedora Extras Quality Assurance
AcceptedBlocker
:
: 1260415 1261803 1262361 (view as bug list)
Depends On:
Blocks: F23BetaBlocker
  Show dependency treegraph
 
Reported: 2015-09-08 02:43 EDT by Adam Williamson
Modified: 2015-09-16 14:36 EDT (History)
17 users (show)

See Also:
Fixed In Version: 23.19.4-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-16 14:36:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log (28.31 KB, text/plain)
2015-09-08 12:09 EDT, Adam Williamson
no flags Details
program.log (97.27 KB, text/plain)
2015-09-08 12:10 EDT, Adam Williamson
no flags Details
journal.log (851.04 KB, text/plain)
2015-09-08 12:10 EDT, Adam Williamson
no flags Details
dnf.log (5.77 KB, text/plain)
2015-09-08 12:11 EDT, Adam Williamson
no flags Details
dnf.rpm.log (75.69 KB, text/plain)
2015-09-08 12:11 EDT, Adam Williamson
no flags Details

  None (edit)
Description Adam Williamson 2015-09-08 02:43:46 EDT
In the 2015-09-07 nightly Fedora 23 images, and also 23 Beta TC4, after fresh install of the system you cannot log in as root. This is not an SELinux issue, at least not obviously: it still occurs if you boot with 'enforcing=0' or 'selinux=0'.

You can log in as a regular user created during install, but you cannot 'su' to root from that user account.

This is pretty mysterious for now, I'm going to look into it more tomorrow. Really not sure what's going wrong. There's no screamingly obvious smoking gun in the 2015-09-07 changes, but this definitely seems to have started breaking in the 2015-09-07 tests in openQA (2015-09-06 tests passed).

One thing I see is these messages in the logs after trying to su:

pam_unix(su:auth): authentication failure; logname=test uid=1000 euid=0 tty=tty1 ruser=test rhost= user=root
pam_succeed_if(su:auth): requirement "uid >= 1000" not met by user "root"

Component is kind of a guess for now.
Comment 1 Adam Williamson 2015-09-08 02:58:15 EDT
Proposing as a Beta blocker. Not being able to access root has an impact on various criteria, let's say "The default system init daemon (e.g. systemd) must be capable of starting, stopping, enabling and disabling correctly-defined services." - can't do that without root. https://fedoraproject.org/wiki/Fedora_23_Alpha_Release_Criteria#System_service_manipulation
Comment 2 Jens Lody 2015-09-08 04:45:01 EDT
I just tested it with the workstation live cd:
using the live medium works fine, but installing on hdd is broken as Adam has described.
I booted into the VM with the live cd and mounted the "real" hdd.
A look into /etc/shadow showed an asterisk ("*") instead of a password-hash for root.
I was able to set the passwd from commandline after chrooting into the installed system.
After a reboot login as root works as expected.
Comment 3 Jens Lody 2015-09-08 04:49:12 EDT
I don't know, if this might be related or not: this was with a weak password where I have to click continue twice (in the installer).
Comment 4 Karel Zak 2015-09-08 06:48:25 EDT
It seems like some trivial anaconda/setup problem with /etc/shadow initialization.
Comment 5 Stephen Gallagher 2015-09-08 09:21:09 EDT
+1 beta blocker.

I reproduced this on the Server Beta TC4 media just now. I entered a complex password for root in Anaconda (so no double-click to continue).

My guess is that this is fallout from the password-policy changes, but I can't confirm that yet.
Comment 6 David Shea 2015-09-08 10:40:46 EDT
Logs, please
Comment 7 Adam Williamson 2015-09-08 12:09:59 EDT
Created attachment 1071402 [details]
anaconda.log
Comment 8 Adam Williamson 2015-09-08 12:10:16 EDT
Created attachment 1071403 [details]
program.log
Comment 9 Adam Williamson 2015-09-08 12:10:35 EDT
Created attachment 1071404 [details]
journal.log
Comment 10 Adam Williamson 2015-09-08 12:11:13 EDT
Created attachment 1071405 [details]
dnf.log
Comment 11 Adam Williamson 2015-09-08 12:11:33 EDT
Created attachment 1071406 [details]
dnf.rpm.log
Comment 12 David Shea 2015-09-08 12:55:02 EDT
*** Bug 1260415 has been marked as a duplicate of this bug. ***
Comment 13 Adam Williamson 2015-09-08 12:57:08 EDT
sgallagh and I think we have a diagnosis and a fix now, just testing it.
Comment 14 Adam Williamson 2015-09-08 13:05:12 EDT
https://github.com/rhinstaller/anaconda/pull/351
Comment 15 Adam Williamson 2015-09-08 13:07:12 EDT
https://www.happyassassin.net/updates/1260875.0.img is an updates.img with the proposed fix for this, if anyone else wants to test.
Comment 16 David Shea 2015-09-10 09:47:40 EDT
*** Bug 1261803 has been marked as a duplicate of this bug. ***
Comment 17 Adam Williamson 2015-09-10 15:16:38 EDT
Discussed at 2015-09-10 blocker review meeting: https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2015-09-10/f23-blocker-review.2015-09-10-16.00.log.txt . Accepted as a beta per criterion "It must be possible to log in to the default Cockpit instance" (with a typical install, the only user who's allowed to login to cockpit is root, so we went with that criterion).
Comment 18 Fedora Update System 2015-09-10 16:27:57 EDT
python-blivet-1.12.3-1.fc23 anaconda-23.19.3-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-15562
Comment 19 Fedora Update System 2015-09-10 23:49:19 EDT
anaconda-23.19.3-1.fc23, python-blivet-1.12.3-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update anaconda python-blivet'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-15562
Comment 20 David Shea 2015-09-11 09:37:07 EDT
*** Bug 1262361 has been marked as a duplicate of this bug. ***
Comment 21 Fedora Update System 2015-09-14 13:22:10 EDT
python-blivet-1.12.4-1.fc23 anaconda-23.19.4-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-15846
Comment 22 Fedora Update System 2015-09-15 12:50:56 EDT
anaconda-23.19.4-1.fc23, python-blivet-1.12.4-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update anaconda python-blivet'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-15846
Comment 23 Adam Williamson 2015-09-15 21:51:07 EDT
Verified in openQA testing.
Comment 24 Fedora Update System 2015-09-16 14:35:47 EDT
anaconda-23.19.4-1.fc23, python-blivet-1.12.4-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.