Bug 1262556 - AttributeError: 'NoneType' object has no attribute 'get_data' (when wifi scan run and AP which does not broadcast SSID is in range)
Summary: AttributeError: 'NoneType' object has no attribute 'get_data' (when wifi scan...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 24
Hardware: x86_64
OS: Unspecified
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker abrt_hash:3583a8cb2b3...
: 1321011 (view as bug list)
Depends On:
Blocks: F24BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2015-09-12 18:25 UTC by Jan Kowalski
Modified: 2016-04-23 23:45 UTC (History)
16 users (show)

Fixed In Version: anaconda-24.13.4-1 anaconda-24.13.4-1.fc24
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-04-23 23:45:52 UTC


Attachments (Terms of Use)
File: anaconda-tb (849.39 KB, text/plain)
2015-09-12 18:25 UTC, Jan Kowalski
no flags Details
File: anaconda.log (14.91 KB, text/plain)
2015-09-12 18:25 UTC, Jan Kowalski
no flags Details
File: environ (486 bytes, text/plain)
2015-09-12 18:25 UTC, Jan Kowalski
no flags Details
File: journalctl (544.17 KB, text/plain)
2015-09-12 18:25 UTC, Jan Kowalski
no flags Details
File: lsblk_output (2.38 KB, text/plain)
2015-09-12 18:25 UTC, Jan Kowalski
no flags Details
File: nmcli_dev_list (2.23 KB, text/plain)
2015-09-12 18:25 UTC, Jan Kowalski
no flags Details
File: os_info (528 bytes, text/plain)
2015-09-12 18:25 UTC, Jan Kowalski
no flags Details
File: program.log (96.26 KB, text/plain)
2015-09-12 18:25 UTC, Jan Kowalski
no flags Details
File: storage.log (186.71 KB, text/plain)
2015-09-12 18:25 UTC, Jan Kowalski
no flags Details
File: ifcfg.log (7.67 KB, text/plain)
2015-09-12 18:25 UTC, Jan Kowalski
no flags Details
journal after triggering the crash with requesting NM logging settings (507.17 KB, text/plain)
2016-04-12 18:30 UTC, Adam Williamson
no flags Details

Description Jan Kowalski 2015-09-12 18:25:05 UTC
Version-Release number of selected component:
anaconda-core-24.2-1.fc24.x86_64

The following was filed automatically by anaconda:
anaconda 24.2-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python3.4/site-packages/pyanaconda/ui/gui/spokes/network.py", line 1072, in _get_strongest_unique_aps
    ssid = ap.get_ssid().get_data()
  File "/usr/lib64/python3.4/site-packages/pyanaconda/ui/gui/spokes/network.py", line 894, in _refresh_ap
    aps = self._get_strongest_unique_aps(dev_cfg.device.get_access_points())
  File "/usr/lib64/python3.4/site-packages/pyanaconda/ui/gui/spokes/network.py", line 819, in refresh_ui
    self._refresh_ap(dev_cfg, state)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/ui/gui/spokes/network.py", line 450, in on_device_selection_changed
    self.refresh_ui()
AttributeError: 'NoneType' object has no attribute 'get_data'

Additional info:
cmdline:        /usr/bin/python3  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-WS-x86_64-rawhide-20 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.3.0-0.rc0.git14.1.fc24.x86_64
other involved packages: anaconda-gui-24.2-1.fc24.x86_64
product:        Fedora
release:        Fedora release 24 (Rawhide)
type:           anaconda
version:        Rawhide

Comment 1 Jan Kowalski 2015-09-12 18:25:18 UTC
Created attachment 1072729 [details]
File: anaconda-tb

Comment 2 Jan Kowalski 2015-09-12 18:25:20 UTC
Created attachment 1072730 [details]
File: anaconda.log

Comment 3 Jan Kowalski 2015-09-12 18:25:22 UTC
Created attachment 1072731 [details]
File: environ

Comment 4 Jan Kowalski 2015-09-12 18:25:31 UTC
Created attachment 1072732 [details]
File: journalctl

Comment 5 Jan Kowalski 2015-09-12 18:25:33 UTC
Created attachment 1072733 [details]
File: lsblk_output

Comment 6 Jan Kowalski 2015-09-12 18:25:34 UTC
Created attachment 1072734 [details]
File: nmcli_dev_list

Comment 7 Jan Kowalski 2015-09-12 18:25:36 UTC
Created attachment 1072735 [details]
File: os_info

Comment 8 Jan Kowalski 2015-09-12 18:25:40 UTC
Created attachment 1072736 [details]
File: program.log

Comment 9 Jan Kowalski 2015-09-12 18:25:44 UTC
Created attachment 1072737 [details]
File: storage.log

Comment 10 Jan Kowalski 2015-09-12 18:25:46 UTC
Created attachment 1072738 [details]
File: ifcfg.log

Comment 11 Alexander Todorov 2015-11-11 11:27:28 UTC
Another user experienced a similar problem:

With the latest Rawhide snapshot I tried to install on a system which doesn't have Ethernet cable plugged in. After going to the network settings spoke I saw eth0 unplugged/off and wifi0. After clicking on wifi0 to eneble it I got this error.

Then plugged in eth0 to report the traceback.

addons:         com_redhat_kdump
cmdline:        /usr/bin/python3  /sbin/anaconda
cmdline_file:   inst.stage2=hd:sda1:/install.img repo=https://kojipkgs.fedoraproject.org/mash/rawhide-20151111/rawhide/x86_64/os sshd=1
hashmarkername: anaconda
kernel:         4.4.0-0.rc0.git6.1.fc24.x86_64
package:        anaconda-24.6-1
product:        Fedora
reason:         AttributeError: 'NoneType' object has no attribute 'get_data'
release:        Cannot get release name.
version:        rawhide

Comment 12 Alexander Todorov 2015-11-11 11:49:08 UTC
In addition to this bug I'm also seeing bug #1280271, but they may not be related.

Comment 13 Joachim Frieben 2015-12-15 19:42:42 UTC
Same error for current Fedora development including packages:
- anaconda-24.8-1.fc24
- kernel-4.4.0-0.rc5.git0.1.fc24

Comment 14 Jan Kurik 2016-02-24 15:50:55 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase

Comment 15 David Shea 2016-03-23 20:44:42 UTC
Pretty sure nm_access_point_get_ssid shouldn't be returning for what appears to be a valid NMAccessPoint object.

Comment 16 David Shea 2016-03-24 13:27:25 UTC
*** Bug 1321011 has been marked as a duplicate of this bug. ***

Comment 17 satellitgo 2016-03-24 13:44:15 UTC
https://bugzilla.redhat.com/show_bug.cgi?id=1321011

Note this was failure on entering networking spoke of 24.13- in Fedora-Everything-netinst-x86_64-24_Alpha-1.7.iso

could not detect wireless AP

DVD to HD bare metal install

Installs fine if use wired connection as detected on boot

Comment 18 satellitgo 2016-03-24 13:49:40 UTC
(In reply to satellitgo from comment #17)
> https://bugzilla.redhat.com/show_bug.cgi?id=1321011
> 
> Note this was failure on entering networking spoke of 24.13- in
> Fedora-Everything-netinst-x86_64-24_Alpha-1.7.iso
> 
> could not detect wireless AP
> 
> DVD to HD bare metal install
> 
> Installs fine if use wired connection as detected on boot

24.13-1

Comment 19 Joachim Frieben 2016-03-28 19:03:41 UTC
(In reply to Joachim Frieben from comment #13)
Wifi connection works well now for Fedora-Workstation-netinst-x86_64-24_Alpha-1.7 boot image.

Comment 20 Adam Williamson 2016-03-28 20:52:21 UTC
I tested Fedora-Everything-netinst x86_64 Alpha 1.7 and hit this crash on reaching the hub screen - I didn't even have to go to the NETWORK spoke. Nominating as a Beta blocker as that impact is pretty bad for me. My test system was a third-gen Dell XPS 13 developer edition with wifi and no ethernet adapter.

Comment 21 Kamil Páral 2016-03-29 17:00:13 UTC
Discussed at today's blocker review meeting [1]. Voted as AcceptedBlocker (Beta) - testing indicates that this bug violates "When using a dedicated installer image, the installer must be able to complete an installation using the text, graphical and VNC installation interfaces." (and other 'complete an install' criteria) for at least some affected systems, likely wifi-only installs from netinst / DVD

[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2016-03-29

Comment 22 Beniamino Galvani 2016-03-30 13:38:10 UTC
How reproducible is this? It would be useful if anybody could provide NM logs obtained after increasing log level by setting this:

 [logging]
 level=DEBUG
 domains=DEFAULT,WIFI_SCAN

in /etc/NetworkManager/NetworkManager.conf (the service must be restarted then). 

Or in alternative:

# nmcli general logging domains DEFAULT,WIFI_SCAN
# nmcli general logging level DEBUG

(this doesn't require restart but changes are not persistent).

Comment 23 Adam Williamson 2016-04-07 23:33:00 UTC
it's easily reproducible for me just by booting an installer image on a system with no ethernet, but it's difficult to get in and tweak the NM config before the crash happens. I'll try and do it one way or another, though.

Comment 24 Adam Williamson 2016-04-08 00:22:29 UTC
oh, never mind, I forgot we can reproduce it on live. Then it should be easy.

Comment 25 Adam Williamson 2016-04-12 18:13:03 UTC
Hmm, I tried with current nightly Workstation live and didn't hit the crash. I'll try it a couple more times with that image and the Everything netinst.

Are other reporters still hitting this with recent nightlies?

https://www.happyassassin.net/nightlies.html

Comment 26 Adam Williamson 2016-04-12 18:22:28 UTC
Aha, OK, in the live case, there's an overlap with https://bugzilla.redhat.com/show_bug.cgi?id=1146232 here: when the virbr0 interface / route is present, the crash doesn't happen. If you destroy it and run the installer, the crash happens.

Comment 27 Adam Williamson 2016-04-12 18:30:44 UTC
Created attachment 1146604 [details]
journal after triggering the crash with requesting NM logging settings

Comment 28 Beniamino Galvani 2016-04-12 20:37:28 UTC
(In reply to Adam Williamson from comment #27)
> Created attachment 1146604 [details]
> journal after triggering the crash with requesting NM logging settings

The 'ssid' field of an AP object can be NULL when the AP is not
broadcasting the SSID, so the client application must be prepared to
handle this situation. See for example:

https://cgit.freedesktop.org/NetworkManager/NetworkManager/tree/examples/python/gi/show-wifi-networks.py#n40

I think this should be solved in anaconda.

Comment 29 Adam Williamson 2016-04-12 20:57:36 UTC
Aha, thanks. So a better / more precise definition of this bug would be that it happens not 'whenever anaconda tries to do wifi scanning' (whether explicitly triggered, or done automatically because there's no wired connection and we need a network), but that it happens 'whenever anaconda tries to do wifi scanning *and there's an AP within range that is set not to broadcast its SSID*'?

Comment 30 Adam Williamson 2016-04-12 22:17:35 UTC
https://github.com/rhinstaller/anaconda/pull/588

Comment 31 Alexander Todorov 2016-04-13 06:27:38 UTC
(In reply to Adam Williamson from comment #29)
> Aha, thanks. So a better / more precise definition of this bug would be that
> it happens not 'whenever anaconda tries to do wifi scanning' (whether
> explicitly triggered, or done automatically because there's no wired
> connection and we need a network), but that it happens 'whenever anaconda
> tries to do wifi scanning *and there's an AP within range that is set not to
> broadcast its SSID*'?

I think you are right. My AP doesn't broadcast its SSID IIRC.

Comment 32 Adam Williamson 2016-04-18 17:31:54 UTC
This was merged, should be in next anaconda build.

Comment 33 Fedora Update System 2016-04-18 20:56:43 UTC
python-blivet-1.20.0-1.fc24 anaconda-24.13.4-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-45ca29d07c

Comment 34 Fedora Update System 2016-04-19 20:25:17 UTC
anaconda-24.13.4-1.fc24, python-blivet-1.20.0-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-45ca29d07c

Comment 35 Fedora Update System 2016-04-23 23:45:21 UTC
anaconda-24.13.4-1.fc24, python-blivet-1.20.0-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.