Bug 1321011 - AttributeError: 'NoneType' object has no attribute 'get_data'
Summary: AttributeError: 'NoneType' object has no attribute 'get_data'
Status: CLOSED DUPLICATE of bug 1262556
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 24
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:3583a8cb2b351705bc32b5ce32d...
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-24 13:19 UTC by satellitgo
Modified: 2016-03-24 13:27 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-03-24 13:27:25 UTC


Attachments (Terms of Use)
File: anaconda-tb (2.23 MB, text/plain)
2016-03-24 13:19 UTC, satellitgo
no flags Details
File: anaconda.log (105.53 KB, text/plain)
2016-03-24 13:19 UTC, satellitgo
no flags Details
File: dnf.log (2.15 KB, text/plain)
2016-03-24 13:19 UTC, satellitgo
no flags Details
File: environ (459 bytes, text/plain)
2016-03-24 13:19 UTC, satellitgo
no flags Details
File: lsblk_output (1.93 KB, text/plain)
2016-03-24 13:19 UTC, satellitgo
no flags Details
File: lvm.log (838.55 KB, text/plain)
2016-03-24 13:19 UTC, satellitgo
no flags Details
File: nmcli_dev_list (1.94 KB, text/plain)
2016-03-24 13:20 UTC, satellitgo
no flags Details
File: os_info (449 bytes, text/plain)
2016-03-24 13:20 UTC, satellitgo
no flags Details
File: storage.log (162.44 KB, text/plain)
2016-03-24 13:20 UTC, satellitgo
no flags Details
File: syslog (973.12 KB, text/plain)
2016-03-24 13:20 UTC, satellitgo
no flags Details
File: ifcfg.log (2.42 KB, text/plain)
2016-03-24 13:20 UTC, satellitgo
no flags Details
File: packaging.log (728 bytes, text/plain)
2016-03-24 13:20 UTC, satellitgo
no flags Details
File: program.log (91.05 KB, application/octet-stream)
2016-03-24 13:20 UTC, satellitgo
no flags Details

Description satellitgo 2016-03-24 13:19:44 UTC
Description of problem:
try to set wireless in anaconda 24-13-1

Version-Release number of selected component:
anaconda-24.13-1

The following was filed automatically by anaconda:
anaconda 24.13-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python3.5/site-packages/pyanaconda/ui/gui/spokes/network.py", line 1082, in _get_strongest_unique_aps
    ssid = ap.get_ssid().get_data()
  File "/usr/lib64/python3.5/site-packages/pyanaconda/ui/gui/spokes/network.py", line 904, in _refresh_ap
    aps = self._get_strongest_unique_aps(dev_cfg.device.get_access_points())
  File "/usr/lib64/python3.5/site-packages/pyanaconda/ui/gui/spokes/network.py", line 829, in refresh_ui
    self._refresh_ap(dev_cfg, state)
  File "/usr/lib64/python3.5/site-packages/pyanaconda/ui/gui/spokes/network.py", line 448, in on_device_selection_changed
    self.refresh_ui()
AttributeError: 'NoneType' object has no attribute 'get_data'

Additional info:
addons:         com_redhat_kdump
cmdline:        /usr/bin/python3  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-E-dvd-x86_64-24 quiet
dnf.rpm.log:    Mar 24 13:14:39 INFO --- logging initialized ---
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.5.0-0.rc7.git0.2.fc24.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        24

Comment 1 satellitgo 2016-03-24 13:19:53 UTC
Created attachment 1139958 [details]
File: anaconda-tb

Comment 2 satellitgo 2016-03-24 13:19:54 UTC
Created attachment 1139959 [details]
File: anaconda.log

Comment 3 satellitgo 2016-03-24 13:19:55 UTC
Created attachment 1139960 [details]
File: dnf.log

Comment 4 satellitgo 2016-03-24 13:19:56 UTC
Created attachment 1139961 [details]
File: environ

Comment 5 satellitgo 2016-03-24 13:19:57 UTC
Created attachment 1139962 [details]
File: lsblk_output

Comment 6 satellitgo 2016-03-24 13:19:59 UTC
Created attachment 1139963 [details]
File: lvm.log

Comment 7 satellitgo 2016-03-24 13:20:01 UTC
Created attachment 1139964 [details]
File: nmcli_dev_list

Comment 8 satellitgo 2016-03-24 13:20:02 UTC
Created attachment 1139965 [details]
File: os_info

Comment 9 satellitgo 2016-03-24 13:20:03 UTC
Created attachment 1139966 [details]
File: storage.log

Comment 10 satellitgo 2016-03-24 13:20:06 UTC
Created attachment 1139967 [details]
File: syslog

Comment 11 satellitgo 2016-03-24 13:20:07 UTC
Created attachment 1139968 [details]
File: ifcfg.log

Comment 12 satellitgo 2016-03-24 13:20:08 UTC
Created attachment 1139969 [details]
File: packaging.log

Comment 13 satellitgo 2016-03-24 13:20:10 UTC
Created attachment 1139970 [details]
File: program.log

Comment 14 David Shea 2016-03-24 13:27:25 UTC

*** This bug has been marked as a duplicate of bug 1262556 ***


Note You need to log in before you can comment on or make changes to this bug.